aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
new file mode 100644
index 0000000000..da22a43deb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python bindings for interacting with systemd over DBus"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[sha256sum] = "d74a814bfda01085db1a8ad90be3cb27daf23a51ab6b03e7e29ec811fa2ae859"
+
+DEPENDS = "systemd python3-cython-native"
+RDEPENDS:${PN} += "python3-xml python3-pprint"
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+inherit pypi setuptools3 features_check pkgconfig
+
+do_configure:prepend() {
+ rm -rf ${S}/pystemd/*.c
+}
+
+BBCLASSEXTEND = "native"