aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/zchunk/zchunk_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/zchunk/zchunk_1.3.1.bb')
-rw-r--r--meta-oe/recipes-support/zchunk/zchunk_1.3.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/zchunk/zchunk_1.3.1.bb b/meta-oe/recipes-support/zchunk/zchunk_1.3.1.bb
new file mode 100644
index 0000000000..9bf3809244
--- /dev/null
+++ b/meta-oe/recipes-support/zchunk/zchunk_1.3.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression"
+AUTHOR = "Jonathan Dieter"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242"
+
+SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main"
+
+SRCREV = "b462b1587f7d3aa782689430e83e96c737748f33"
+S = "${WORKDIR}/git"
+
+DEPENDS = "zstd"
+DEPENDS:append:libc-musl = " argp-standalone"
+
+inherit meson pkgconfig lib_package
+
+PACKAGECONFIG ??= "openssl zckdl"
+
+# zckdl gets packaged into zchunk-bin
+PACKAGECONFIG[zckdl] = "-Dwith-curl=enabled,-Dwith-curl=disabled,curl"
+# Use OpenSSL primitives for SHA
+PACKAGECONFIG[openssl] = "-Dwith-openssl=enabled,-Dwith-openssl=disabled,openssl"
+
+BBCLASSEXTEND = "native nativesdk"