aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libharu/libharu_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libharu/libharu_2.3.0.bb')
-rw-r--r--meta-oe/recipes-support/libharu/libharu_2.3.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libharu/libharu_2.3.0.bb b/meta-oe/recipes-support/libharu/libharu_2.3.0.bb
new file mode 100644
index 0000000000..7477c5f03b
--- /dev/null
+++ b/meta-oe/recipes-support/libharu/libharu_2.3.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "free PDF library"
+HOMEPAGE = "http://libharu.org"
+DESCRIPTION = "libHaru is a library for generating PDF files. \
+ It is free, open source, written in ANSI C and cross platform. "
+
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://README;md5=3ee6bc1f64d9cc7907f44840c8e50cb1"
+
+SRC_URI = "git://github.com/libharu/libharu.git;branch=2_3;protocol=https \
+ file://libharu-RELEASE_2_3_0_cmake.patch \
+ file://0001-Install-static-lib-into-var-libdir-rather-than-hardc.patch \
+ "
+
+SRCREV = "4ae1d5f4c84459f130bf1b1ef4c5c330af8eca5d"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+DEPENDS += "libpng zlib"
+
+do_install:append() {
+ mkdir -p ${D}/${datadir}/libharu
+ mv ${D}/libharu ${D}/${datadir}
+}