aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/hwdata/hwdata_0.370.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/hwdata/hwdata_0.370.bb')
-rw-r--r--meta-oe/recipes-support/hwdata/hwdata_0.370.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/hwdata/hwdata_0.370.bb b/meta-oe/recipes-support/hwdata/hwdata_0.370.bb
new file mode 100644
index 0000000000..56d4253772
--- /dev/null
+++ b/meta-oe/recipes-support/hwdata/hwdata_0.370.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Hardware identification and configuration data"
+HOMEPAGE = "https://github.com/vcrhonek/hwdata"
+SECTION = "System/Base"
+
+LICENSE = "GPL-2.0-or-later | XFree86-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
+
+SRCREV = "21cb47beb1716545b25dfe8ae1b9e079c73b85d9"
+SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_configure() {
+ ${S}/configure --datadir=${datadir} --libdir=${libdir}
+}
+
+do_compile[noexec] = "1"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES:${PN} = "${libdir}/* \
+ ${datadir}/* "