aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb')
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb22
1 files changed, 13 insertions, 9 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
index 30d41a16e6..aa595ebe52 100644
--- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -7,29 +7,33 @@ system-wide input gesture recognition mechanism."
HOMEPAGE = "https://launchpad.net/geis"
-LICENSE = "GPLv3 & LGPLv3"
+LICENSE = "GPL-3.0-only & LGPL-3.0-only"
LIC_FILES_CHKSUM = " \
file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \
file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
"
-inherit autotools pkgconfig python3native lib_package distro_features_check
+inherit autotools pkgconfig python3native lib_package features_check
-REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame"
SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz \
file://fix-indentation-for-gcc6.patch \
file://0001-libgeis-Compare-the-first-character-of-string-to-nul.patch \
+ file://0001-provide-function-declaration-with-prototypes.patch \
"
+
+UPSTREAM_CHECK_URI = "https://launchpad.net/geis/trunk"
+
SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf"
SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb"
EXTRA_OECONF = "--disable-integration-tests"
-FILES_${PN}-bin = "${bindir}"
-RDEPENDS_${PN}-bin = " \
+FILES:${PN}-bin = "${bindir}"
+RDEPENDS:${PN}-bin = " \
python3-compression \
python3-core \
python3-crypt \
@@ -42,14 +46,14 @@ RDEPENDS_${PN}-bin = " \
python3-threading \
"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/geisview \
${libdir}/${PYTHON_DIR}/site-packages/geis* \
${libdir}/${PYTHON_DIR}/site-packages/_*.so \
"
-FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
+FILES:${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
-FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
+FILES:${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
-FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"
+FILES:${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"