aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/c-periphery/c-periphery_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/c-periphery/c-periphery_2.4.2.bb')
-rw-r--r--meta-oe/recipes-support/c-periphery/c-periphery_2.4.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/c-periphery/c-periphery_2.4.2.bb b/meta-oe/recipes-support/c-periphery/c-periphery_2.4.2.bb
new file mode 100644
index 0000000000..8e38517448
--- /dev/null
+++ b/meta-oe/recipes-support/c-periphery/c-periphery_2.4.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "C-Periphery lib used to access GPIO, LED, PWM, SPI, I2C, MMIO, Serial"
+DESCRIPTION = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux"
+
+HOMEPAGE = "https://github.com/vsergeev/c-periphery"
+
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=be30d45bdc453f70a494c149c2168289"
+
+SRC_URI = "git://github.com/vsergeev/c-periphery;protocol=https;branch=master"
+SRCREV = "91f9678d2a35a3af3c633f20165bdde8bea32209"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
+
+BBCLASSEXTEND = "native nativesdk"
+