aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch8
-rw-r--r--meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch8
-rw-r--r--meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch8
-rw-r--r--meta-oe/recipes-multimedia/esound/esound/no-docs.patch18
4 files changed, 22 insertions, 20 deletions
diff --git a/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch b/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch
index 6c7f3bd30d..130f3c2290 100644
--- a/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch
+++ b/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch
@@ -1,9 +1,10 @@
-From a860fe0796c43e35eac9783140fcb563cab9f55a Mon Sep 17 00:00:00 2001
+From 945df2da87a412758ceab4ac5711abbb269a47c1 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 8 Jun 2017 23:09:51 -0700
-Subject: [PATCH 1/3] audio_alsa09.c: alsa drain fix
+Subject: [PATCH] audio_alsa09.c: alsa drain fix
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
audio_alsa09.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -21,6 +22,3 @@ index 534e3db..d9450e6 100644
if (alsadbg)
print_state();
---
-2.13.1
-
diff --git a/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch b/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch
index 337546abe9..10a6ba03ae 100644
--- a/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch
+++ b/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch
@@ -1,11 +1,12 @@
-From 1fbee6e96384f340b816e221fe1c2f3ff0b487bf Mon Sep 17 00:00:00 2001
+From e218d5a0a545ebb9623d62da5cfca478f9c90fce Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 8 Jun 2017 23:11:31 -0700
-Subject: [PATCH 2/3] Undefine open64 and fopen64
+Subject: [PATCH] Undefine open64 and fopen64
Since the signatures do not match with libc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
esddsp.c | 2 ++
1 file changed, 2 insertions(+)
@@ -30,6 +31,3 @@ index d3c6ea9..17b5949 100644
FILE *
fopen64 (const char *path, const char *mode)
{
---
-2.13.1
-
diff --git a/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch b/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch
index 62c880d9d0..83365b4e6f 100644
--- a/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch
+++ b/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch
@@ -1,12 +1,13 @@
-From 979a02d9ec9c28686021cd2b49ca55d2195c9dce Mon Sep 17 00:00:00 2001
+From 89c62db54716d514e639f9e1bfd3c1f7d82641dd Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 8 Jun 2017 23:12:36 -0700
-Subject: [PATCH 3/3] Use -I=<path> in configure
+Subject: [PATCH] Use -I=<path> in configure
This helps to use proper sysroot in
cross build environment
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
@@ -33,6 +34,3 @@ index 5645dce..d374cda 100644
SOUND_LIBS=-lmme
esac
fi
---
-2.13.1
-
diff --git a/meta-oe/recipes-multimedia/esound/esound/no-docs.patch b/meta-oe/recipes-multimedia/esound/esound/no-docs.patch
index fc69f1a038..8a546e6db1 100644
--- a/meta-oe/recipes-multimedia/esound/esound/no-docs.patch
+++ b/meta-oe/recipes-multimedia/esound/esound/no-docs.patch
@@ -1,11 +1,19 @@
-Index: esound-0.2.36/Makefile.am
-===================================================================
---- esound-0.2.36.orig/Makefile.am
-+++ esound-0.2.36/Makefile.am
+From bfcaa9bdc70440db96f10afc0c2a792870f75acb Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 3 Jun 2011 19:39:02 +0200
+
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 08c4c94..ede9d26 100644
+--- a/Makefile.am
++++ b/Makefile.am
@@ -1,5 +1,5 @@
-SUBDIRS = docs
+SUBDIRS =
- ACLOCAL_FLAGS = -I m4
+ ACLOCAL_AMFLAGS = -I m4