aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/x11vnc/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/x11vnc/files')
-rw-r--r--meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch24
-rw-r--r--meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch86
-rw-r--r--meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch6
3 files changed, 3 insertions, 113 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch b/meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch
deleted file mode 100644
index f2a538bf63..0000000000
--- a/meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-libvncserver: replace LIBVNCSERVER_WORDS_BIGENDIAN with WORDS_BIGENDIAN
-
-since macro AC_C_BIGENDIAN is used in autoconf and WORDS_BIGENDIAN is
-automatically set for different arch, it is better to use WORDS_BIGENDIAN
-instead of LIBVNCSERVER_WORDS_BIGENDIAN, which cuase issue in mips.
-
-Signed-off-by: Yu Ke <ke.yu@intel.com>
-
-Upstream-Status: Pending
-
-diff --git a/libvncserver/main.c b/libvncserver/main.c
-index b6bd930..8bbb7bf 100644
---- a/libvncserver/main.c
-+++ b/libvncserver/main.c
-@@ -47,7 +47,7 @@ static MUTEX(extMutex);
-
- static int rfbEnableLogging=1;
-
--#ifdef LIBVNCSERVER_WORDS_BIGENDIAN
-+#ifdef WORDS_BIGENDIAN
- char rfbEndianTest = (1==0);
- #else
- char rfbEndianTest = (1==1);
-
diff --git a/meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch b/meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch
deleted file mode 100644
index 8e894bd8e7..0000000000
--- a/meta-oe/recipes-graphics/x11vnc/files/remove-redundant-RPATH.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From 7be055c13c7d0d640941830a3291af3b404928c1 Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Mon, 27 Jun 2016 04:44:14 -0400
-Subject: [PATCH] configure.ac: remove redundant RPATH
-
-It caused oe QA issue:
-...
-|ERROR: QA Issue: x11vnc: work/i586-poky-linux/x11vnc/0.9.13-r0/packages-split/
-x11vnc/usr/bin/x11vnc contains probably-redundant RPATH /usr/lib [useless-rpaths]
-...
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- configure.ac | 21 +++++----------------
- 1 file changed, 5 insertions(+), 16 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 6f664d0..f986686 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -330,10 +330,8 @@ if test "x$with_crypto" != "xno" -a "x$with_ssl" != "xno"; then
- saved_LDFLAGS="$LDFLAGS"
- CPPFLAGS="$CPPFLAGS -I$with_ssl/include"
- LDFLAGS="$LDFLAGS -L$with_ssl/lib"
-- if test "x$ld_minus_R" = "xno"; then
-+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
- :
-- elif test "x$GCC" = "xyes"; then
-- LDFLAGS="$LDFLAGS -Xlinker -R$with_ssl/lib"
- else
- LDFLAGS="$LDFLAGS -R$with_ssl/lib"
- fi
-@@ -447,10 +445,8 @@ if test ! -z "$with_system_libvncserver" -a "x$with_system_libvncserver" != "xno
- fi
- if test "x$with_system_libvncserver" != "xyes"; then
- rflag=""
-- if test "x$ld_minus_R" = "xno"; then
-+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
- :
-- elif test "x$GCC" = "xyes"; then
-- rflag="-Xlinker -R$with_system_libvncserver/lib"
- else
- rflag="-R$with_system_libvncserver/lib"
- fi
-@@ -484,10 +480,8 @@ new enough.
- elif libvncserver-config --version 1>/dev/null 2>&1; then
- rflag=""
- rprefix=`libvncserver-config --prefix`
-- if test "x$ld_minus_R" = "xno"; then
-+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
- :
-- elif test "x$GCC" = "xyes"; then
-- rflag=" -Xlinker -R$rprefix/lib "
- else
- rflag=" -R$rprefix/lib "
- fi
-@@ -541,11 +535,8 @@ if test "x$with_jpeg" != "xno"; then
- saved_LDFLAGS="$LDFLAGS"
- CPPFLAGS="$CPPFLAGS -I$with_jpeg/include"
- LDFLAGS="$LDFLAGS -L$with_jpeg/lib"
-- if test "x$ld_minus_R" = "xno"; then
-+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
- :
-- elif test "x$GCC" = "xyes"; then
-- # this is not complete... in general a rat's nest.
-- LDFLAGS="$LDFLAGS -Xlinker -R$with_jpeg/lib"
- else
- LDFLAGS="$LDFLAGS -R$with_jpeg/lib"
- fi
-@@ -590,10 +581,8 @@ if test "x$with_zlib" != "xno" -a "x$with_libz" != "xno"; then
- saved_LDFLAGS="$LDFLAGS"
- CPPFLAGS="$CPPFLAGS -I$with_zlib/include"
- LDFLAGS="$LDFLAGS -L$with_zlib/lib"
-- if test "x$ld_minus_R" = "xno"; then
-+ if test "x$ld_minus_R" = "xno" -o "x$GCC" = "xyes"; then
- :
-- elif test "x$GCC" = "xyes"; then
-- LDFLAGS="$LDFLAGS -Xlinker -R$with_zlib/lib"
- else
- LDFLAGS="$LDFLAGS -R$with_zlib/lib"
- fi
---
-2.8.1
-
diff --git a/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch b/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch
index f62e405dd1..060319c76b 100644
--- a/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch
+++ b/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch
@@ -10,10 +10,10 @@ Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Upstream-Status: Inappropriate [configuration]
-Index: x11vnc-0.9.12/x11vnc/x11vnc.desktop
+Index: x11vnc-0.9.12/x11vnc.desktop
===================================================================
---- x11vnc-0.9.12.orig/x11vnc/x11vnc.desktop 2011-03-03 10:33:18.000000000 +0800
-+++ x11vnc-0.9.12/x11vnc/x11vnc.desktop 2011-03-03 10:35:20.000000000 +0800
+--- x11vnc-0.9.12.orig/x11vnc.desktop 2011-03-03 10:33:18.000000000 +0800
++++ x11vnc-0.9.12/x11vnc.desktop 2011-03-03 10:35:20.000000000 +0800
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=X11VNC Server