aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/feh/feh_3.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/feh/feh_3.10.bb')
-rw-r--r--meta-oe/recipes-graphics/feh/feh_3.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/feh/feh_3.10.bb b/meta-oe/recipes-graphics/feh/feh_3.10.bb
new file mode 100644
index 0000000000..0f0e61893a
--- /dev/null
+++ b/meta-oe/recipes-graphics/feh/feh_3.10.bb
@@ -0,0 +1,31 @@
+SUMMARY = "X11 image viewer aimed mostly at console users"
+AUTHOR = "Tom Gilbert & Daniel Friesel"
+HOMEPAGE = "https://feh.finalrewind.org/"
+SECTION = "x11/utils"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f91bd06901085c94bdc50649d98c5059"
+DEPENDS = "\
+ imlib2 \
+ virtual/libx11 libxt\
+"
+
+SRC_URI = "https://feh.finalrewind.org/feh-${PV}.tar.bz2"
+SRC_URI[sha256sum] = "1d71d1f6dcfe9ffee5e2766969a11978f7eb4fac7d7ae556f104c11f9c57cc98"
+
+inherit mime-xdg features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
+EXTRA_OEMAKE = "curl=0 xinerama=0 PREFIX=/usr"
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install app=1 'DESTDIR=${D}' 'ICON_PREFIX=${D}${datadir}/icons'
+}
+
+RDEPENDS:${PN} += "imlib2-loaders"
+
+FILES:${PN} += "${datadir}/icons"