aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb')
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
new file mode 100644
index 0000000000..945e2c3274
--- /dev/null
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
@@ -0,0 +1,30 @@
+SUMMARY = "System performance benchmark"
+HOMEPAGE = "http://github.com/akopytov/sysbench"
+SECTION = "console/tests"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libtool libaio luajit concurrencykit"
+
+inherit autotools-brokensep pkgconfig
+
+# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
+# Launchpad until the next release is available from Github.
+SRC_URI = "git://github.com/akopytov/sysbench.git;protocol=https;branch=master"
+SRCREV = "ebf1c90da05dea94648165e4f149abc20c979557"
+
+S = "${WORKDIR}/git"
+
+COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64).*-linux*"
+
+EXTRA_OECONF += "--enable-largefile --with-system-luajit --with-system-ck --without-gcc-arch"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
+PACKAGECONFIG[mysql] = "--with-mysql \
+ --with-mysql-includes=${STAGING_INCDIR}/mysql \
+ --with-mysql-libs=${STAGING_LIBDIR}, \
+ --without-mysql,mysql5"
+
+do_configure:prepend() {
+ touch ${S}/NEWS ${S}/AUTHORS
+}