aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
index 0fc342560a..efea3fab74 100644
--- a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
+++ b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
@@ -16,6 +16,8 @@ S = "${WORKDIR}/git"
inherit autotools manpages pkgconfig ptest
+DEPENDS += "ctags-native"
+
PACKAGECONFIG ?= "\
async openssl tcp \
${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
@@ -42,6 +44,10 @@ python () {
export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
+do_compile:prepend() {
+ oe_runmake update-map-file
+}
+
do_install_ptest () {
install -d ${D}${PTEST_PATH}
install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest