aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-04 15:00:12 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-04 15:04:22 -0700
commitd30990f519667c35585f88f849afc5c59bf411bf (patch)
tree16107039426da7e37d6546a51936ec17cc9e3eb6
parent60027c2fe2654be8c0b33cdb68374a89da98a6c0 (diff)
downloadmeta-openembedded-contrib-d30990f519667c35585f88f849afc5c59bf411bf.tar.gz
libcoap: Build linker symbol file explicitly
Since we autoreconf, it should be better to build the linker map file too, which requires ctags during build. This is otherwise flagged as error by lld linker where we specify a linker symbol file on cmdline but the file is not there. Fixes | libtool: error: symbol file './libcoap-3.sym' does not exist Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
index 0fc342560a..efea3fab74 100644
--- a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
+++ b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
@@ -16,6 +16,8 @@ S = "${WORKDIR}/git"
inherit autotools manpages pkgconfig ptest
+DEPENDS += "ctags-native"
+
PACKAGECONFIG ?= "\
async openssl tcp \
${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
@@ -42,6 +44,10 @@ python () {
export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
+do_compile:prepend() {
+ oe_runmake update-map-file
+}
+
do_install_ptest () {
install -d ${D}${PTEST_PATH}
install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest