aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJasper Orschulko <jasper@fancydomain.eu>2023-06-26 13:45:32 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-26 05:12:55 -0700
commite5dc8ed33ccff7f5c9212d5ed9f1baabf9af06d6 (patch)
tree2a9722e78586a8c21f9c315c8fb317d168405f37 /meta-python
parent1c39d1a1936ce440fd62239944b511b4a0bf48b4 (diff)
downloadmeta-openembedded-contrib-e5dc8ed33ccff7f5c9212d5ed9f1baabf9af06d6.tar.gz
python3-pyproject-api: Add initial recipe 1.5.1
Dependency for python3-tox Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyproject-api_1.5.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyproject-api_1.5.1.bb b/meta-python/recipes-devtools/python/python3-pyproject-api_1.5.1.bb
new file mode 100644
index 0000000000..1b458fa2df
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyproject-api_1.5.1.bb
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: MIT
+# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
+
+SUMMARY = "pyproject-api aims to abstract away interaction with pyproject.toml style projects in a flexible way."
+HOMEPAGE = "https://pyproject-api.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7"
+
+SRC_URI[sha256sum] = "435f46547a9ff22cf4208ee274fca3e2869aeb062a4834adfc99a4dd64af3cf9"
+
+PYPI_PACKAGE = "pyproject_api"
+
+BBCLASSEXTEND = "native nativesdk"
+inherit pypi python_hatchling
+
+DEPENDS += "\
+ ${PYTHON_PN}-hatch-vcs-native \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-tomli \
+"