aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-17 11:20:31 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-17 10:38:28 -0700
commit8b6923579b4b599e524b7815d4b752ea46fa0c64 (patch)
tree027eece49984e60192f0887c59f58e7ff6608051 /meta-python
parent5efd06fb99a55d396db793dc7d4ad5be5d61e81d (diff)
downloadmeta-openembedded-contrib-8b6923579b4b599e524b7815d4b752ea46fa0c64.tar.gz
python3-bandit: add python3-rich to RDEPENDS
bandit wasn't imported properly without the rich module, so add it. Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb b/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb
index 5e2a7e8bc5..bccdf284e5 100644
--- a/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb
@@ -8,6 +8,14 @@ DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six
inherit setuptools3 pypi
-RDEPENDS:${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+RDEPENDS:${PN} += "\
+ python3-git \
+ python3-modules \
+ python3-pbr \
+ python3-pyyaml \
+ python3-rich \
+ python3-six \
+ python3-stevedore \
+ "
BBCLASSEXTEND = "native"