aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-11-30 14:13:55 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-09 12:02:17 +0100
commit6a8d57c0b7e243a22730f637295d620d08b975e0 (patch)
tree2d3e3ecb9deedcc4e9fe1ea6e7198c8cf1793bb5 /meta-python
parent4bb23bc4c444c79052ca6e79e5799d4c5db1e6da (diff)
downloadmeta-openembedded-contrib-6a8d57c0b7e243a22730f637295d620d08b975e0.tar.gz
python-cryptography: update to version 1.6
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.6.bb (renamed from meta-python/recipes-devtools/python/python-cryptography_1.4.bb)7
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_1.6.bb (renamed from meta-python/recipes-devtools/python/python3-cryptography_1.4.bb)0
3 files changed, 19 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography.inc b/meta-python/recipes-devtools/python/python-cryptography.inc
index d4767b1d95..50483bdfd2 100644
--- a/meta-python/recipes-devtools/python/python-cryptography.inc
+++ b/meta-python/recipes-devtools/python/python-cryptography.inc
@@ -1,6 +1,6 @@
SUMMARY = "Provides cryptographic recipes and primitives to python developers"
LICENSE = "Apache-2.0 | BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f375ab4f6b9a7c9eec25377c52d3aa1"
DEPENDS += " \
${PYTHON_PN}-cffi \
@@ -9,18 +9,27 @@ DEPENDS += " \
${PYTHON_PN}-six \
"
-SRC_URI[md5sum] = "a9763e3831cc7cdb402c028fac1ceb39"
-SRC_URI[sha256sum] = "bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128"
+SRC_URI[md5sum] = "33ed393be75f04cd889a02a11acbab39"
+SRC_URI[sha256sum] = "4d0d86d2c8d3fc89133c3fa0d164a688a458b6663ab6fa965c80d6c2cdaf9b3f"
RDEPENDS_${PN} += " \
${PYTHON_PN}-cffi \
${PYTHON_PN}-idna \
- ${PYTHON_PN}-numbers \
${PYTHON_PN}-pyasn1 \
${PYTHON_PN}-pycparser \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-six \
+"
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pycparser \
${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
${PYTHON_PN}-threading \
"
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python-cryptography_1.6.bb
index b05c615101..f5b1e0b3b5 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.6.bb
@@ -10,7 +10,12 @@ DEPENDS += " \
"
RDEPENDS_${PN} += " \
- ${PYTHON_PN}-contextlib \
${PYTHON_PN}-enum34 \
${PYTHON_PN}-ipaddress \
"
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+ ${PYTHON_PN}-contextlib \
+"
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography_1.6.bb
index f807042ec0..f807042ec0 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_1.6.bb