aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-10 09:04:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:36 +0200
commit63ebe282aa03ac8e5d39d1017e743695d0795c41 (patch)
tree28969da9da3b5b09b7fdc19234111e82b5a3a807 /meta-python
parentaa16b3173655c3d89991d56d2081d7e15e7b420e (diff)
downloadmeta-openembedded-contrib-63ebe282aa03ac8e5d39d1017e743695d0795c41.tar.gz
python-urllib3: correct RDEPENDS to work on a minimal python instance
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-urllib3_1.16.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-urllib3_1.16.bb b/meta-python/recipes-devtools/python/python-urllib3_1.16.bb
index 9479f9642b..87a2852777 100644
--- a/meta-python/recipes-devtools/python/python-urllib3_1.16.bb
+++ b/meta-python/recipes-devtools/python/python-urllib3_1.16.bb
@@ -8,4 +8,9 @@ SRC_URI[sha256sum] = "63d479478ddfc83bbc11577dc16d47835c5179ac13e550118ca143b62c
inherit pypi setuptools
-RDEPENDS_${PN} += "python-netclient"
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-zlib \
+ "