aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJasper Orschulko <jasper@fancydomain.eu>2023-06-26 13:45:30 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-26 05:12:55 -0700
commit2956f275bebb4685b7488bd37f3d6d67cbb050d8 (patch)
treefa6e01a1309e0dc5af8d78bfc7296d0c8c30c2d2 /meta-python
parent9c189241332b716e70ef8b91a46e81e49f5e45e0 (diff)
downloadmeta-openembedded-contrib-2956f275bebb4685b7488bd37f3d6d67cbb050d8.tar.gz
python3-filelock: Add initial recipe 3.12.0
Dependency for python3-virtualenv and python3-tox Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-filelock_3.12.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-filelock_3.12.0.bb b/meta-python/recipes-devtools/python/python3-filelock_3.12.0.bb
new file mode 100644
index 0000000000..8deca31b5b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-filelock_3.12.0.bb
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: MIT
+# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
+
+SUMMARY = "A single module, which implements a platform independent file lock in Python, which provides a simple way of inter-process communication"
+HOMEPAGE = "https://py-filelock.readthedocs.io/"
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=911690f51af322440237a253d695d19f"
+
+SRC_URI[sha256sum] = "fc03ae43288c013d2ea83c8597001b1129db351aad9c57fe2409327916b8e718"
+
+UPSTREAM_CHECK_URI = "https://pypi.org/project/lockfile/"
+UPSTREAM_CHECK_REGEX = "/lockfile/(?P<pver>(\d+[\.\-_]*)+)"
+
+BBCLASSEXTEND = "native nativesdk"
+inherit pypi python_hatchling
+
+DEPENDS += "\
+ ${PYTHON_PN}-hatch-vcs-native \
+"