aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2023-07-17 13:12:37 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-17 10:38:28 -0700
commit0e3f5e5201e3b9740b74df76a2a907983cc8b4e3 (patch)
treea0a6ff99ef68a3bcefa422144344d4b597b11d63 /meta-python
parent4f93bd2c85fed86ca859a65f7b19453f66917e12 (diff)
downloadmeta-openembedded-contrib-0e3f5e5201e3b9740b74df76a2a907983cc8b4e3.tar.gz
python3-pytest-asyncio: upgrade 0.16.0 -> 0.21.1
0.21.1 - Output a proper error message when an invalid asyncio_mode is selected. - Extend warning message about unclosed event loops with additional possible cause. #531 - Previously, some tests reported "skipped" or "xfailed" as a result. Now all tests report a "success" result. 0.21.0 - Drop compatibility with pytest 6.1. Pytest-asyncio now depends on pytest 7.0 or newer. - pytest-asyncio cleans up any stale event loops when setting up and tearing down the event_loop fixture. This behavior has been deprecated and pytest-asyncio emits a DeprecationWarning when tearing down the event_loop fixture and current event loop has not been closed. 0.18.2 (22-03-03) - Fix asyncio auto mode not marking static methods. #295 - Fix a compatibility issue with Hypothesis 6.39.0. #302 0.18.1 (22-02-10) - Fixes a regression that prevented async fixtures from working in synchronous tests. #286 0.18.0 (22-02-07) - Raise a warning if @pytest.mark.asyncio is applied to non-async function. #275 - Support parametrized event_loop fixture. #278 0.17.2 (22-01-17) - Require typing-extensions on Python<3.8 only. #269 - Fix a regression in tests collection introduced by 0.17.1, the plugin works fine with non-python tests again. #267 0.17.1 (22-01-16) - Fixes a bug that prevents async Hypothesis tests from working without explicit asyncio marker when --asyncio-mode=auto is set. #258 - Fixed a bug that closes the default event loop if the loop doesn't exist #257 - Added type annotations. 0.17.0 (22-01-13) - [pytest-asyncio]{.title-ref} no longer alters existing event loop policies. #168, #188 - Drop support for Python 3.6 - Fixed an issue when pytest-asyncio was used in combination with [flaky]{.title-ref} or inherited asynchronous Hypothesis tests. #178 #231 - Added flaky to test dependencies - Added unused_udp_port and unused_udp_port_factory fixtures (similar to unused_tcp_port and unused_tcp_port_factory counterparts. #99 - Added the plugin modes: strict, auto, and legacy. See documentation for details. #125 - Correctly process KeyboardInterrupt during async fixture setup phase #219 License-Update: whitespace Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.16.0.bb14
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.21.1.bb16
2 files changed, 16 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.16.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.16.0.bb
deleted file mode 100644
index 1dfeab6332..0000000000
--- a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.16.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
-
-SRC_URI[sha256sum] = "7496c5977ce88c34379df64a66459fe395cd05543f0a2f837016e7144391fcfb"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
- ${PYTHON_PN}-pytest \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.21.1.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.21.1.bb
new file mode 100644
index 0000000000..c96c0e0801
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.21.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=136e4f49dbf29942c572a3a8f6e88a77"
+
+SRC_URI[sha256sum] = "40a7eae6dded22c7b604986855ea48400ab15b069ae38116e8c01238e9eeb64d"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ python3-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"