aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-pyyaml_3.10.bb
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
committerTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
commita6acceb1dc1d391e20c3722e685aa7c9cca313b3 (patch)
treec31a773a177c030ed638252f99755c9be8ec9c12 /meta-python/recipes-python/python-pyyaml_3.10.bb
parentdf9ed3b72b1920938e4c79c20cdd288a1d7b16a8 (diff)
downloadmeta-openembedded-contrib-timo/meta-python.tar.gz
meta-python: move recipes from meta-oetimo/meta-python
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python-pyyaml_3.10.bb')
-rw-r--r--meta-python/recipes-python/python-pyyaml_3.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-pyyaml_3.10.bb b/meta-python/recipes-python/python-pyyaml_3.10.bb
new file mode 100644
index 0000000000..100e1c81ac
--- /dev/null
+++ b/meta-python/recipes-python/python-pyyaml_3.10.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python support for YAML"
+HOMEPAGE = "http://www.pyyaml.org"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
+DEPENDS = "libyaml python-cython-native"
+
+SRC_URI = "http://pyyaml.org/download/pyyaml/PyYAML-${PV}.tar.gz \
+ file://setup.py \
+"
+
+SRC_URI[md5sum] = "74c94a383886519e9e7b3dd1ee540247"
+SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d46fe7c"
+
+S = "${WORKDIR}/PyYAML-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ # upstream setup.py overcomplicated, use ours
+ install -m 0644 ${WORKDIR}/setup.py ${S}
+}