aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-06 09:03:25 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-07 11:32:47 -0700
commit8e110d9c5cf22520af4b69fe4f6b90709f2c7545 (patch)
tree4b0c1491d28327fc248c676e20908a4664c6899e /meta-perl
parentbd78c3760953278fc22555283b01588393f5993b (diff)
downloadmeta-openembedded-contrib-8e110d9c5cf22520af4b69fe4f6b90709f2c7545.tar.gz
libencode-perl: Remove buildpaths from generated .exh files
there are generated .exh files which has the absolute perl interpreter path in comments, which is caught by build QA, therefore remove the absolute perl native path prefix Fixes warnings like WARNING: libencode-perl-3.19-r0 do_package_qa: QA Issue: File /usr/src/debug/libencode-perl/3.19-r0/def_t.exh in package libencode-perl-src contains reference to TMPDIR [buildpaths] Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libencode/libencode-perl_3.19.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-perl/recipes-perl/libencode/libencode-perl_3.19.bb b/meta-perl/recipes-perl/libencode/libencode-perl_3.19.bb
index 352517ca67..79934e2229 100644
--- a/meta-perl/recipes-perl/libencode/libencode-perl_3.19.bb
+++ b/meta-perl/recipes-perl/libencode/libencode-perl_3.19.bb
@@ -21,8 +21,8 @@ UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
S = "${WORKDIR}/Encode-${PV}"
+#EXTRA_CPANFLAGS:append = "PERL=../recipe-sysroot-native/usr/bin/perl-native/perl"
inherit cpan ptest-perl
-
do_install:prepend() {
# Requires "-T" (taint) option on command line
rm -rf ${B}/t/taint.t
@@ -32,6 +32,10 @@ do_install:prepend() {
rm -rf ${B}/t/use-Encode-Alias.t
}
+do_install:append() {
+ sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native||g" ${S}/*/*.exh ${S}/*.exh
+}
+
do_install_ptest() {
mkdir ${D}${PTEST_PATH}/bin
cp -r ${B}/bin/piconv ${D}${PTEST_PATH}/bin