aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2018-05-24 14:26:50 -0400
committerKhem Raj <raj.khem@gmail.com>2018-05-29 12:56:19 -0700
commita5e0b35c70f62ee14cc53e9b6edfb1bb448400a0 (patch)
tree514da49f8156e8c6ef16a60b4406dbb095c611ce /meta-oe
parent2d07e06ce9cf2c6b9dfb339e396514bf7a351bdd (diff)
downloadmeta-openembedded-contrib-a5e0b35c70f62ee14cc53e9b6edfb1bb448400a0.tar.gz
libssh: variable cleanup
Reorder recipe variables according to: https://www.openembedded.org/wiki/Styleguide Originally-conceived-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.7.3.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.7.3.bb b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
index e5ea2b8bfa..6064969ae0 100644
--- a/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
+++ b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
@@ -1,16 +1,21 @@
SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
HOMEPAGE = "http://www.libssh.org"
SECTION = "libs"
-
-DEPENDS = "zlib openssl libgcrypt"
-
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+DEPENDS = "zlib openssl libgcrypt"
+
SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d"
+
S = "${WORKDIR}/git"
+inherit cmake
+
+PACKAGECONFIG ??=""
+PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+
EXTRA_OECMAKE = " \
-DWITH_GCRYPT=1 \
-DWITH_PCAP=1 \
@@ -19,11 +24,6 @@ EXTRA_OECMAKE = " \
-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
"
-PACKAGECONFIG ??=""
-PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
-
-inherit cmake
-
do_configure_prepend () {
# Disable building of examples
sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \