aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAvinash Reddy Palleti <avinash.reddy.palleti@intel.com>2018-08-17 09:47:39 +0530
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit4dfe0fe8ed9a02aed37a9503cd8da70de64be906 (patch)
tree4d59912e4d375be087f2e54de9fca3256f12a4e1 /meta-oe
parent8a2a36e66ba392317acab180b6cefa8139ef8fa2 (diff)
downloadmeta-openembedded-contrib-4dfe0fe8ed9a02aed37a9503cd8da70de64be906.tar.gz
cpuid: Fix build with glibc 2.28+
Include sys/sysmacros.h for cpuid.c Upstream-Status:Pending Signed-off-by: Avinash Reddy Palleti <avinash.reddy.palleti@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb3
-rw-r--r--meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch24
2 files changed, 26 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb b/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb
index 7a70f75763..5dd1bdd4ee 100644
--- a/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb
+++ b/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb
@@ -6,7 +6,8 @@ UMC, NexGen, Rise, and SiS CPUs"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz"
+SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
+ file://0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch"
SRC_URI[md5sum] = "1c46a6662626c5a6eaca626f23a5a7d7"
SRC_URI[sha256sum] = "667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865"
diff --git a/meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch b/meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch
new file mode 100644
index 0000000000..985182e3bd
--- /dev/null
+++ b/meta-oe/recipes-devtools/cpuid/files/0001-Fix-Add-sys-sysmacros.h-to-fix-build-issue.patch
@@ -0,0 +1,24 @@
+From 2693a499d4eec4504962e85a9713fa6431d3025f Mon Sep 17 00:00:00 2001
+From: Avinash Reddy Palleti <avinash.reddy.palleti@intel.com>
+Date: Thu, 16 Aug 2018 22:36:31 +0530
+Subject: [PATCH] Fix: Add sys/sysmacros.h to fix build issue
+
+---
+ cpuid.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cpuid.c b/cpuid.c
+index 3c94837..0a98616 100644
+--- a/cpuid.c
++++ b/cpuid.c
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <unistd.h>
+--
+2.7.4
+