aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-01 07:30:55 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-01 07:33:42 -0700
commit3990b23ec73771917e13ee648c3173b5cbe46b6a (patch)
tree251989d7eb7f6e55aab76ff44f7ac7e59ba722cc /meta-oe
parent0ae88cd387f12a7316b8886088af190837412118 (diff)
downloadmeta-openembedded-contrib-3990b23ec73771917e13ee648c3173b5cbe46b6a.tar.gz
pidgin-sipe: Add packageconfig to turn Werror on/off
This component has many warnings and is using deprecated libxml2 interfaces as distros its better to disable Werror, if devs want to enable it then add the needed packageconfig explicitly. Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb
index 90e1701488..6ce42ec187 100644
--- a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb
+++ b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb
@@ -25,6 +25,8 @@ PACKAGECONFIG[krb5] = "--with-krb5=yes,--with-krb5=no,krb5"
PACKAGECONFIG[telepathy] = "--enable-telepathy=yes,--enable-telepathy=no,telepathy-glib"
#PACKAGECONFIG[gssapi_only] = "--enable-gssapi-only=yes,--enable-gssapi-only=no,krb5"
PACKAGECONFIG[debug] = "--enable-debug=yes,--enable-debug=no,valgrind"
+# disable Werror by default, useful for dev mode
+PACKAGECONFIG[quality] = "--enable-quality-check=yes,--enable-quality-check=no,"
FILES:${PN}-dev += " \
${libdir}/purple-2/*.la \
@@ -35,5 +37,3 @@ FILES:${PN} += " \
${datadir}/appdata \
${datadir}/metainfo \
"
-
-CFLAGS = "-Wno-error=deprecated-declarations"