aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2022-04-20 00:09:03 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-20 10:58:01 -0700
commitcf260fb4ed6b5423b7d1906483e0195c445ff95e (patch)
tree8c18dad892867483370f05a379d65afe091c18c8 /meta-oe/recipes-navigation
parent1d7385bba58cdd0bf9647f357fe28eb5c120659d (diff)
downloadmeta-openembedded-contrib-cf260fb4ed6b5423b7d1906483e0195c445ff95e.tar.gz
gpsd: Only copy the Python files if they are created
If one adds some configuration that disables the creation of the Python files, e.g., minimal=yes, then the installation fails when it tries to copy the non-existent files. Avoid this by checking for their existence before copying them. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb
index c11d4c76d6..22706f097a 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb
@@ -73,8 +73,10 @@ do_install:append() {
install -m 0644 ${S}/packaging/deb/etc_default_gpsd ${D}${sysconfdir}/default/gpsd.default
# Support for python
- install -d ${D}${PYTHON_SITEPACKAGES_DIR}/gps
- install -m 755 ${D}${libdir}/gps/*.py ${D}${PYTHON_SITEPACKAGES_DIR}/gps
+ if [ -d ${D}${libdir}/gps ]; then
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}/gps
+ install -m 755 ${D}${libdir}/gps/*.py ${D}${PYTHON_SITEPACKAGES_DIR}/gps
+ fi
}
PACKAGES =+ "libgps python3-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"