aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2022-12-20 10:00:37 +0100
committerKhem Raj <raj.khem@gmail.com>2022-12-23 08:52:22 -0800
commitaddf0065b3b668d7afba6cd59bb06603aec1d9f7 (patch)
tree35e2e179151ac778352ba15116fa4ae9be399e86 /meta-oe/recipes-navigation
parentd2ad9efcd7d667276731082ecc4a9a6616c2febd (diff)
downloadmeta-openembedded-contrib-addf0065b3b668d7afba6cd59bb06603aec1d9f7.tar.gz
geoclue: fix polkit files only with modem-gps PACKAGECONFIG
* this directory is created only when modem-gps-source option is enabled in meson * fix indentation to use 4 spaces instead of tabs Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.6.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.6.0.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.6.0.bb
index 61b37cd9e8..798a9c16b6 100644
--- a/meta-oe/recipes-navigation/geoclue/geoclue_2.6.0.bb
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.6.0.bb
@@ -38,9 +38,11 @@ USERADD_PACKAGES = "${PN}"
USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
do_install:append() {
- #Fix up permissions on polkit rules.d to work with rpm4 constraints
- chmod 700 ${D}/${datadir}/polkit-1/rules.d
- chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
+ if ${@bb.utils.contains('PACKAGECONFIG', 'modem-gps', 'true', 'false', d)}; then
+ # Fix up permissions on polkit rules.d to work with rpm4 constraints
+ chmod 700 ${D}/${datadir}/polkit-1/rules.d
+ chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
+ fi
}
FILES:${PN} += " \