aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-06-09 14:40:30 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-14 14:51:15 +0200
commite846a439f3be8ccde00ac156a0d74d417878de29 (patch)
treea21a59e7749f7ec458ce3d117cc6e0a9cc4fb76b /meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb
parentd483a70d22505863036635cbff13963e00cfe093 (diff)
downloadmeta-openembedded-contrib-e846a439f3be8ccde00ac156a0d74d417878de29.tar.gz
agent-proxy: add new recipe
agent-proxy is a simple, small proxy which is intended for use with kgdb, or gdbserver type connections where you want to share a text console and a debug session. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb')
-rw-r--r--meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb b/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb
new file mode 100644
index 0000000000..8e370f962c
--- /dev/null
+++ b/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Proxy for UDP/TCP debug connections"
+DESCRIPTION = "The agent-proxy will forward tcp or udp connections as well as allow for script multiplexing of terminal sessions."
+HOMEPAGE = "http://kgdb.wiki.kernel.org/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SECTION = "devel"
+
+EXTRA_OEMAKE = "'CC=${CC}'"
+
+SRCREV = "e6c9d3d996bd55e7ab14dbd74deb7841e0c3a4f1"
+PV = "1.96+git${SRCPV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git;protocol=git \
+ file://0001-Makefile-Add-LDFLAGS-variable.patch \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 agent-proxy ${D}${bindir}
+}