aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2023-05-09 04:43:51 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-09 10:12:44 -0700
commit1278e8cfcab28219136bc7ee7e12fd6460f11985 (patch)
tree65d924af8cf48be1f5d6fa4f51d18c3e8c7d28ea /meta-oe/recipes-graphics
parent6a2fb1f751307f29cafdd3f35fc8452f93d37d0c (diff)
downloadmeta-openembedded-contrib-1278e8cfcab28219136bc7ee7e12fd6460f11985.tar.gz
lvgl: Add configurable color depth, default to 32bpp
Make color depth configurable and default to 32bpp . Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_8.3.7.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.3.7.bb b/meta-oe/recipes-graphics/lvgl/lvgl_8.3.7.bb
index 5f3fc44cfe..a3fd7e04cb 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_8.3.7.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_8.3.7.bb
@@ -20,6 +20,7 @@ EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${baselib}"
S = "${WORKDIR}/git"
LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"
+LVGL_CONFIG_LV_COLOR_DEPTH ?= "32"
# Upstream does not support a default configuration
# but propose a default "disabled" template, which is used as reference
@@ -27,6 +28,8 @@ LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"
do_configure:prepend() {
[ -r "${S}/lv_conf.h" ] \
|| sed -e 's|#if 0 .*Set it to "1" to enable .*|#if 1 // Enabled|g' \
+ -e "s|\(#define LV_COLOR_DEPTH \).*|\1 ${LVGL_CONFIG_LV_COLOR_DEPTH}|g" \
+ \
-e "s|\(#define LV_MEM_CUSTOM .*\)0|\1${LVGL_CONFIG_LV_MEM_CUSTOM}|g" \
\
-e "s|\(#define LV_TICK_CUSTOM \).*|\1 1|g" \