aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-06-21 07:39:29 +0100
committerKhem Raj <raj.khem@gmail.com>2023-06-20 23:45:06 -0700
commit1aaf1023e0ff49942af0fa7bbbfa90c73310fa51 (patch)
treef304dae7d2116450a8def92072e7b823fcf060e7 /meta-oe/recipes-extended
parent9cb5f5c6e91612674eb02f79437abbd51ad7b38f (diff)
downloadmeta-openembedded-contrib-1aaf1023e0ff49942af0fa7bbbfa90c73310fa51.tar.gz
ostree: Upgrade 2023.3 -> 2023.4
Drop upstreamed gpg_strerror_r fix. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-lib-deploy-Use-off_t-not-__off_t.patch27
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-libostree-Link-with-libgpg-error-for-gpg_strerror_r-.patch31
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2023.4.bb (renamed from meta-oe/recipes-extended/ostree/ostree_2023.3.bb)11
3 files changed, 32 insertions, 37 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-lib-deploy-Use-off_t-not-__off_t.patch b/meta-oe/recipes-extended/ostree/ostree/0001-lib-deploy-Use-off_t-not-__off_t.patch
new file mode 100644
index 0000000000..a64d9de5ef
--- /dev/null
+++ b/meta-oe/recipes-extended/ostree/ostree/0001-lib-deploy-Use-off_t-not-__off_t.patch
@@ -0,0 +1,27 @@
+From 6d690ebf64ce640afce3085f01da8694a04853a9 Mon Sep 17 00:00:00 2001
+From: Alex Kiernan <alex.kiernan@gmail.com>
+Date: Tue, 20 Jun 2023 19:24:04 +0100
+Subject: [PATCH] lib/deploy: Use off_t not __off_t
+
+Not clear why this was __off_t which is the sole appearance in the code
+base, but it breaks musl builds.
+
+Upstream-Status: Submitted [https://github.com/ostreedev/ostree/pull/2896]
+Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
+---
+ src/libostree/ostree-sysroot-deploy.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libostree/ostree-sysroot-deploy.c b/src/libostree/ostree-sysroot-deploy.c
+index 8fcd5e802758..2454a5877d94 100644
+--- a/src/libostree/ostree-sysroot-deploy.c
++++ b/src/libostree/ostree-sysroot-deploy.c
+@@ -2536,7 +2536,7 @@ get_kernel_layout_size (OstreeSysroot *self, OstreeDeployment *deployment, guint
+ /* This is a roundabout but more trustworthy way of doing a space check than
+ * relying on statvfs's f_bfree when you know the size of the objects. */
+ static gboolean
+-dfd_fallocate_check (int dfd, __off_t len, gboolean *out_passed, GError **error)
++dfd_fallocate_check (int dfd, off_t len, gboolean *out_passed, GError **error)
+ {
+ /* If the requested size is 0 then return early. Passing a 0 len to
+ * fallocate results in EINVAL */
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-libostree-Link-with-libgpg-error-for-gpg_strerror_r-.patch b/meta-oe/recipes-extended/ostree/ostree/0001-libostree-Link-with-libgpg-error-for-gpg_strerror_r-.patch
deleted file mode 100644
index b87a41bfbb..0000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-libostree-Link-with-libgpg-error-for-gpg_strerror_r-.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 597120777ff9410b715c19298df824ce3170d6d7 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 12 Jun 2023 14:04:44 -0700
-Subject: [PATCH] libostree: Link with libgpg-error for gpg_strerror_r API
-
-With f461c02bb55bf2853a3b81ed5c8618040ab54e98 use of gpg_strerror_r
-was added this symbol comes from libgpg-error however, therefore its
-needed to add -lgpg-error to cmdline to resolve this symbol especially
-with gold and lld linker. Fixes
-
-aarch64-yoe-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: gpg_strerror_r
->>> referenced by ./.libs/libostree-1.so
-
-Upstream-Status: Submitted [https://github.com/ostreedev/ostree/pull/2880]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Makefile-libostree.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -243,8 +243,7 @@ AC_ARG_WITH(gpgme,
- [], [with_gpgme=yes])
- AS_IF([test x$with_gpgme != xno], [
- have_gpgme=yes
-- PKG_CHECK_MODULES([OT_DEP_GPGME], gpgme >= $LIBGPGME_DEPENDENCY, [], have_gpgme=no)
-- PKG_CHECK_MODULES([OT_DEP_GPG_ERROR], [gpg-error], [], have_gpgme=no)
-+ PKG_CHECK_MODULES([OT_DEP_GPGME], [gpgme >= $LIBGPGME_DEPENDENCY gpg-error], [have_gpgme=yes], [have_gpgme=no])
- ]
- )
- AS_IF([test x$with_gpgme != xno && test x$have_gpgme != xyes], [
diff --git a/meta-oe/recipes-extended/ostree/ostree_2023.3.bb b/meta-oe/recipes-extended/ostree/ostree_2023.4.bb
index f5cd7d6ac6..d2a7b04562 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2023.3.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2023.4.bb
@@ -19,12 +19,11 @@ DEPENDS = " \
"
GITHUB_BASE_URI = "https://github.com/ostreedev/ostree/releases"
-SRC_URI = " \
- ${GITHUB_BASE_URI}/download/v${PV}/libostree-${PV}.tar.xz \
- file://0001-libostree-Link-with-libgpg-error-for-gpg_strerror_r-.patch \
- file://run-ptest \
-"
-SRC_URI[sha256sum] = "9c575a094da2c307769f0aee15de95470c3b5550cbff211fbbc4f6fc75f333b1"
+SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/libostree-${PV}.tar.xz \
+ file://run-ptest \
+ file://0001-lib-deploy-Use-off_t-not-__off_t.patch \
+ "
+SRC_URI[sha256sum] = "7cee8ace6aae3c778527927a85abefbfbd491c021f52ae229c51ca3077f9c5d1"
S = "${WORKDIR}/libostree-${PV}"