aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRadek Dostal <radek.dostal@streamunlimited.com>2018-08-28 09:15:32 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commitbae481e9331f1357660df1720221134fefabc526 (patch)
tree07ac749201500c67cb11156693e15f78db793f3b /meta-networking
parentfd8a326652ddb2ccad49ec93a3bdaa3ea4c1207a (diff)
downloadmeta-openembedded-contrib-bae481e9331f1357660df1720221134fefabc526.tar.gz
wireless-regdb: make wireless-regdb architecture independent
There is no compilation involved in wireless-regdb and package should produce the same results on all architectures => making it allarch saves build time. Additionally this fixes issue: "On machines where ${libdir} equals to /usr/lib64/ regulatory.bin is not found by crda". Reason was that crda-3.18/crda.c looks only in following paths: "/usr/local/lib/crda/regulatory.bin", /* Users/preloads can override */ "/usr/lib/crda/regulatory.bin", /* General distribution package usage */ "/lib/crda/regulatory.bin", /* alternative for distributions */ Signed-off-by: Radek Dostál <radek.dostal@streamunlimited.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb b/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb
index d1c8d56759..2b990db3cb 100644
--- a/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb
+++ b/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2018.05.31.bb
@@ -8,12 +8,12 @@ SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
SRC_URI[md5sum] = "0cbbdc21186c76cf58aba01b03f3dc5b"
SRC_URI[sha256sum] = "e1dfbc3b97771373077f430c3c05082fae883145b37db5b2cfd12c56676fbe7b"
-inherit bin_package
+inherit bin_package allarch
do_install() {
- install -d -m0755 ${D}${libdir}/crda
+ install -d -m0755 ${D}${nonarch_libdir}/crda
install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
- install -m 0644 regulatory.bin ${D}${libdir}/crda/regulatory.bin
+ install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db