aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-04 23:48:50 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-06 11:38:16 -0800
commitcff659d47e9288da8f564efc565d042c9c29349e (patch)
tree2e5361b49a5752f3d25cb181bcc308abadca5935 /meta-multimedia
parentb11ebfa37b89f221a19967cf49d4a74bf357c7ea (diff)
downloadmeta-openembedded-contrib-cff659d47e9288da8f564efc565d042c9c29349e.tar.gz
mycroft: Check for pulseaudio in distro features
It needs pulseaudio but its only available via distro features so check it before enabling this recipe Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb b/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
index aab43ea297..6797899808 100644
--- a/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
+++ b/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
@@ -22,7 +22,7 @@ SRC_URI = "git://github.com/MycroftAI/mycroft-core.git;branch=master;protocol=ht
S = "${WORKDIR}/git"
-inherit systemd
+inherit systemd features_check
# Mycroft installs itself on the host
# Just copy the setup files to the rootfs
@@ -91,3 +91,5 @@ RDEPENDS:${PN} += "procps"
RDEPENDS:${PN} += "bash jq libnotify"
SYSTEMD_SERVICE:${PN} = "mycroft-setup.service mycroft.service"
+
+REQUIRED_DISTRO_FEATURES += "pulseaudio"