aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gtk-engines/files
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-06-07 14:45:51 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-22 17:12:36 +0200
commit19ef3affb2f4d475e40eabe8fa1e1c640088aafe (patch)
treef46e6d31403026cbbf82ea07484c436ee0f04d14 /meta-gnome/recipes-gnome/gtk-engines/files
parent9cd117a5dc5f26133a855d1cc3bf9604ae178685 (diff)
downloadmeta-openembedded-contrib-19ef3affb2f4d475e40eabe8fa1e1c640088aafe.tar.gz
gtk-engines: Move from oe-core
gtk-engines is being removed from oe-core (as there will be no themes there that need an engine). Move recipe to meta-gnome since gnome-themes depends on gtk-engines. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gtk-engines/files')
-rw-r--r--meta-gnome/recipes-gnome/gtk-engines/files/glib-2.32.patch23
-rw-r--r--meta-gnome/recipes-gnome/gtk-engines/files/substitute-tests.patch37
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gtk-engines/files/glib-2.32.patch b/meta-gnome/recipes-gnome/gtk-engines/files/glib-2.32.patch
new file mode 100644
index 0000000000..f0b878d376
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gtk-engines/files/glib-2.32.patch
@@ -0,0 +1,23 @@
+From 8d49a386f467cbf8e0842d2218126f643e50f834 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Sun, 27 Nov 2011 14:24:57 +0000
+Subject: Fix build with glib 2.31: Only glib.h can be #include'd. Fixes bug #664914
+
+Upstream-Status: Backport
+
+---
+diff --git a/engines/clearlooks/src/animation.c b/engines/clearlooks/src/animation.c
+index 1f7a41f..56a9286 100644
+--- a/engines/clearlooks/src/animation.c
++++ b/engines/clearlooks/src/animation.c
+@@ -28,7 +28,7 @@
+ #include "animation.h"
+
+ #ifdef HAVE_WORKING_ANIMATION
+-#include <glib/gtimer.h>
++#include <glib.h>
+
+ struct _AnimationInfo {
+ GTimer *timer;
+--
+cgit v0.9.0.2
diff --git a/meta-gnome/recipes-gnome/gtk-engines/files/substitute-tests.patch b/meta-gnome/recipes-gnome/gtk-engines/files/substitute-tests.patch
new file mode 100644
index 0000000000..5c557ba689
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gtk-engines/files/substitute-tests.patch
@@ -0,0 +1,37 @@
+Upstream-Status: Pending
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+diff -Nurd gtk-engines-2.20.2/configure.ac gtk-engines-2.20.2/configure.ac
+--- gtk-engines-2.20.2/configure.ac 2010-10-01 15:42:37.000000000 +0300
++++ gtk-engines-2.20.2/configure.ac 2013-08-20 02:50:27.930510565 +0300
+@@ -166,6 +166,9 @@
+
+ AC_SUBST(DEVELOPMENT_CFLAGS)
+
++AC_SUBST([exported_symbols_tests], [[$(EXPORTED_SYMBOLS_TESTS)]])
++AC_SUBST([torture_test_tests], [[$(TORTURE_TEST_TESTS)]])
++
+ AM_CONFIG_HEADER([engines/support/config.h])
+
+ AC_CONFIG_FILES([
+diff -Nurd gtk-engines-2.20.2/test/Makefile.am gtk-engines-2.20.2/test/Makefile.am
+--- gtk-engines-2.20.2/test/Makefile.am 2010-09-19 18:18:21.000000000 +0300
++++ gtk-engines-2.20.2/test/Makefile.am 2013-08-20 02:50:36.842510865 +0300
+@@ -66,7 +66,7 @@
+ # Prefix with exported_
+ EXPORTED_SYMBOLS_TESTS = $(patsubst %,exported_%,$(BUILD_ENGINES))
+
+-TESTS += $(EXPORTED_SYMBOLS_TESTS)
++TESTS += @exported_symbols_tests@
+
+
+ #############################################################
+@@ -88,7 +88,7 @@
+ TORTURE_TEST_TESTS = torture_buildin $(patsubst %,torture_%,$(TORTURE_TEST_ENGINES))
+
+ # Add TORTURE_TEST_ENGINES to list of tests
+-TESTS += $(TORTURE_TEST_TESTS)
++TESTS += @torture_test_tests@
+
+ # Possible other tests:
+ # - An extensive theme switch tests that loads/unloads the engine