aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-05 11:16:00 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-06 12:54:03 -0700
commitfc9a72ed804253a39d2a4fcef62202abcbb23567 (patch)
treebed03d4ec3ff03583cf39f546bb2550c7dd84473
parent243c83334a77c6052b4170ded98f7198b06a33fe (diff)
downloadmeta-openembedded-contrib-fc9a72ed804253a39d2a4fcef62202abcbb23567.tar.gz
sdbus-c++-libsystemd: Fix build with kernel 5.15+
Backport a patch from upstream systemd Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd-243/0001-basic-linux-Sync-if_arp.h-with-Linux-5.14.patch29
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_243.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd-243/0001-basic-linux-Sync-if_arp.h-with-Linux-5.14.patch b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd-243/0001-basic-linux-Sync-if_arp.h-with-Linux-5.14.patch
new file mode 100644
index 0000000000..a251e3e6c2
--- /dev/null
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd-243/0001-basic-linux-Sync-if_arp.h-with-Linux-5.14.patch
@@ -0,0 +1,29 @@
+From 4411a9a3ebff98b6fcf5967c75faa458d219df96 Mon Sep 17 00:00:00 2001
+From: Chris Packham <chris.packham@alliedtelesis.co.nz>
+Date: Fri, 10 Sep 2021 09:51:36 +1200
+Subject: [PATCH] basic/linux: Sync if_arp.h with Linux 5.14
+
+ARPHRD_MCTP was added in 5.14. Sync if_arp.h to pick up the definition
+
+Fixes #20694
+Upstream-Status: Backport [https://github.com/cpackham-atlnz/systemd/commit/67cd626399b0d02882ee00716c8bd31ba764c862]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/basic/linux/if_arp.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/basic/linux/if_arp.h b/src/basic/linux/if_arp.h
+index c3cc5a9e5e..4783af9fe5 100644
+--- a/src/basic/linux/if_arp.h
++++ b/src/basic/linux/if_arp.h
+@@ -54,6 +54,7 @@
+ #define ARPHRD_X25 271 /* CCITT X.25 */
+ #define ARPHRD_HWX25 272 /* Boards with X.25 in firmware */
+ #define ARPHRD_CAN 280 /* Controller Area Network */
++#define ARPHRD_MCTP 290
+ #define ARPHRD_PPP 512
+ #define ARPHRD_CISCO 513 /* Cisco HDLC */
+ #define ARPHRD_HDLC ARPHRD_CISCO
+--
+2.33.1
+
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_243.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_243.bb
index a81b57526d..d50681d77b 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_243.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-libsystemd_243.bb
@@ -15,6 +15,7 @@ SRCBRANCH = "v243-stable"
SRC_URI = "git://github.com/systemd/systemd-stable.git;protocol=https;branch=${SRCBRANCH} \
file://static-libsystemd-pkgconfig.patch \
file://7c5fd25119a495009ea62f79e5daec34cc464628.patch \
+ file://0001-basic-linux-Sync-if_arp.h-with-Linux-5.14.patch \
"
# patches needed by musl