aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2023-04-02 13:45:58 -0700
committerTim Orling <tim.orling@konsulko.com>2023-04-02 14:14:49 -0700
commitfba331aeb47d0113f5d5c51008a60bbac9d5b2cd (patch)
treee7b3c02a8568be127a3d213c3605fa459c85d33b
parenteb10fe4ee76016ecb9395c32bb41ca50b9bcd2a2 (diff)
downloadmeta-openembedded-contrib-fba331aeb47d0113f5d5c51008a60bbac9d5b2cd.tar.gz
python3-aspectlib: fix ptest
* ptest RDEPENDS on pytest * Use python3-unittest-automake-output instead of using sed to reformat the output use this new module. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb
index 416b031c5e..d2b0864caa 100644
--- a/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb
@@ -21,8 +21,10 @@ do_install_ptest() {
}
RDEPENDS:${PN}-ptest += "\
- python3-tornado \
python3-process-tests \
+ python3-pytest \
+ python3-tornado \
+ python3-unittest-automake-output \
"
RDEPENDS:${PN} += "python3-core python3-fields"