aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-05-31 10:23:10 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-06 23:07:58 -0700
commite74592c1cb32942ba54a1bac9e969785f982e873 (patch)
treed2887eadc7aefb41cf204720f0032f7f4048b893
parent2980505c414cce26337d7205c2bf82c96edc21f2 (diff)
downloadmeta-openembedded-contrib-e74592c1cb32942ba54a1bac9e969785f982e873.tar.gz
python3-pyusb: fix run-time dependencies
Add the missing dependency on ctypes and drop libusb1 from RDEPENDS as it will be already present in the rootfs thanks to being in project's build-time dependencies. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb b/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb
index 286e9672b1..abe3529119 100644
--- a/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb
@@ -13,6 +13,6 @@ SRC_URI[sha256sum] = "a4cc7404a203144754164b8b40994e2849fde1cfff06b08492f12fff9d
inherit pypi setuptools3
-RDEPENDS:${PN} += "libusb1"
+RDEPENDS:${PN} += "python3-ctypes"
BBCLASSEXTEND = "native nativesdk"