aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-16 10:54:00 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:27 +0200
commitd48c95da5873a5674c264f788c0f1dda12025a25 (patch)
tree6592862bd5f083b747a00e6ebfe2fdf9a4082946
parentf40bce43638234c18e09b6a9601c737c21f26993 (diff)
downloadmeta-openembedded-contrib-d48c95da5873a5674c264f788c0f1dda12025a25.tar.gz
dnsmasq: move to meta-networking and tweak
* Make dbus a PACKAGECONFIG option and remove dnsmasq-dbus recipe * Set LICENSE to correctly indicate choice of licenses * Set SUMMARY instead of DESCRIPTION Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq.inc (renamed from meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc)13
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq_2.55.bb (renamed from meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb)0
-rwxr-xr-xmeta-networking/recipes-support/dnsmasq/files/dnsmasq.conf (renamed from meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.conf)0
-rw-r--r--meta-networking/recipes-support/dnsmasq/files/dnsmasq.service (renamed from meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service)0
-rw-r--r--meta-networking/recipes-support/dnsmasq/files/init (renamed from meta-oe/recipes-connectivity/dnsmasq/files/init)0
-rw-r--r--meta-oe/recipes-connectivity/dnsmasq/dnsmasq-dbus_2.55.bb13
6 files changed, 11 insertions, 15 deletions
diff --git a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
index 46188a4450..0f5b27325a 100644
--- a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq.inc
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
@@ -1,8 +1,8 @@
-DESCRIPTION = "Dnsmasq is a lightweight, easy to configure DNS forwarder and DHCP server."
+SUMMARY = "Lightweight, easy to configure DNS forwarder and DHCP server"
HOMEPAGE = "http://www.thekelleys.org.uk/dnsmasq/doc.html"
SECTION = "console/network"
# GPLv3 was added in version 2.41 as license option
-LICENSE = "GPLv2 GPLv3"
+LICENSE = "GPLv2 | GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://COPYING-v3;md5=d32239bcb673463ab874e80d47fae504"
@@ -18,6 +18,10 @@ inherit update-rc.d systemd
INITSCRIPT_NAME = "dnsmasq"
INITSCRIPT_PARAMS = "defaults"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[dbus] = "COPTS=-DHAVE_DBUS,,dbus"
+EXTRA_OEMAKE = "${EXTRA_OECONF}"
+
do_install () {
oe_runmake "PREFIX=${D}${prefix}" \
"BINDIR=${D}${bindir}" \
@@ -29,6 +33,11 @@ do_install () {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/dnsmasq.service ${D}${systemd_unitdir}/system
+
+ if [ "${@base_contains('PACKAGECONFIG', 'dbus', 'dbus', '', d)}" != "" ]; then
+ install -d ${D}${sysconfdir}/dbus-1/system.d
+ install -m 644 dbus/dnsmasq.conf ${D}${sysconfdir}/dbus-1/system.d/
+ fi
}
CONFFILES_${PN} = "${sysconfdir}/dnsmasq.conf"
diff --git a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb b/meta-networking/recipes-support/dnsmasq/dnsmasq_2.55.bb
index ae37db7391..ae37db7391 100644
--- a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bb
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq_2.55.bb
diff --git a/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.conf b/meta-networking/recipes-support/dnsmasq/files/dnsmasq.conf
index 1a198a3791..1a198a3791 100755
--- a/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.conf
+++ b/meta-networking/recipes-support/dnsmasq/files/dnsmasq.conf
diff --git a/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service b/meta-networking/recipes-support/dnsmasq/files/dnsmasq.service
index 549e15e2b2..549e15e2b2 100644
--- a/meta-oe/recipes-connectivity/dnsmasq/files/dnsmasq.service
+++ b/meta-networking/recipes-support/dnsmasq/files/dnsmasq.service
diff --git a/meta-oe/recipes-connectivity/dnsmasq/files/init b/meta-networking/recipes-support/dnsmasq/files/init
index d1aa9e517d..d1aa9e517d 100644
--- a/meta-oe/recipes-connectivity/dnsmasq/files/init
+++ b/meta-networking/recipes-support/dnsmasq/files/init
diff --git a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq-dbus_2.55.bb b/meta-oe/recipes-connectivity/dnsmasq/dnsmasq-dbus_2.55.bb
deleted file mode 100644
index 7d698c6c1d..0000000000
--- a/meta-oe/recipes-connectivity/dnsmasq/dnsmasq-dbus_2.55.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-# dnsmasq with support for DBus interface
-
-require dnsmasq_${PV}.bb
-
-S = "${WORKDIR}/dnsmasq-${PV}"
-
-DEPENDS = "dbus"
-EXTRA_OEMAKE = "COPTS=-DHAVE_DBUS"
-
-do_install_append () {
- install -d ${D}${sysconfdir}/dbus-1/system.d
- install -m 644 dbus/dnsmasq.conf ${D}${sysconfdir}/dbus-1/system.d/
-}