aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-14 15:31:01 +0000
committerKhem Raj <raj.khem@gmail.com>2022-01-18 08:59:58 -0800
commitd32bb7dbc08ea979138776bf4fb4d794b70f9b96 (patch)
treed7e01885e56ffe3865b4e443f8540f018d07518f
parent4de2215997a060ad719ef79ea888428fd072c55f (diff)
downloadmeta-openembedded-contrib-d32bb7dbc08ea979138776bf4fb4d794b70f9b96.tar.gz
python3-dbussy: port to setuptools
Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-dbussy/setuptools.patch56
-rw-r--r--meta-python/recipes-devtools/python/python3-dbussy_1.3.bb6
2 files changed, 59 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dbussy/setuptools.patch b/meta-python/recipes-devtools/python/python3-dbussy/setuptools.patch
new file mode 100644
index 0000000000..3506f76d02
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbussy/setuptools.patch
@@ -0,0 +1,56 @@
+Port setup.py to setuptools.
+
+Upstream-Status: Submitted [https://github.com/ldo/dbussy/pull/53]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+diff --git a/setup.py b/setup.py
+index 4b9411e..da7ee7e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -8,33 +8,9 @@
+ # Written by Lawrence D'Oliveiro <ldo@geek-central.gen.nz>.
+ #-
+
+-import sys
+-import distutils.core
+-from distutils.command.build import \
+- build as std_build
++import setuptools
+
+-class my_build(std_build) :
+- "customization of build to perform additional validation."
+-
+- def run(self) :
+- try :
+- exec \
+- (
+- "async def dummy() :\n"
+- " pass\n"
+- "#end dummy\n"
+- )
+- except SyntaxError :
+- sys.stderr.write("This module requires Python 3.5 or later.\n")
+- sys.exit(-1)
+- #end try
+- super().run()
+- #end run
+-
+-#end my_build
+-
+-distutils.core.setup \
+- (
++setuptools.setup(
+ name = "DBussy",
+ version = "1.3",
+ description = "language bindings for libdbus, for Python 3.5 or later",
+@@ -43,9 +19,5 @@ distutils.core.setup \
+ author_email = "ldo@geek-central.gen.nz",
+ url = "https://github.com/ldo/dbussy",
+ license = "LGPL v2.1+",
+ py_modules = ["dbussy", "ravel"],
+- cmdclass =
+- {
+- "build" : my_build,
+- },
+- )
++)
diff --git a/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb b/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
index 061893df3e..0cf9dc8a7d 100644
--- a/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
@@ -3,13 +3,14 @@ HOMEPAGE = "https://github.com/ldo/dbussy"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
-SRC_URI = "git://github.com/ldo/dbussy.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/ldo/dbussy.git;branch=master;protocol=https \
+ file://setuptools.patch"
SRCREV = "37ede4242b48def73ada46c2747a4c5cae6abf45"
S = "${WORKDIR}/git"
-inherit distutils3
+inherit setuptools3
RDEPENDS:${PN} += "\
python3-asyncio \
@@ -19,4 +20,3 @@ RDEPENDS:${PN} += "\
"
BBCLASSEXTEND = "native nativesdk"
-