aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-03 17:21:16 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-03 14:45:54 -0700
commitd226fa318d2fe792b9198899bdd98b1dd4e12e6b (patch)
tree6610978108d115d920403f1c45c5f05f32e34030
parent586337819d38325a409d212c9bdb5819bd4ab775 (diff)
downloadmeta-openembedded-contrib-d226fa318d2fe792b9198899bdd98b1dd4e12e6b.tar.gz
python-xxhash: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-xxhash.inc22
-rw-r--r--meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb24
2 files changed, 22 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-xxhash.inc b/meta-python/recipes-devtools/python/python-xxhash.inc
deleted file mode 100644
index c02c29eb78..0000000000
--- a/meta-python/recipes-devtools/python/python-xxhash.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
-SECTION = "devel/python"
-LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
-
-SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0"
-SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9"
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-inherit ptest
-
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}
diff --git a/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb b/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb
index 76bc41a11c..c114a6c8bc 100644
--- a/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb
+++ b/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb
@@ -1,2 +1,22 @@
-require python-xxhash.inc
-inherit pypi setuptools3
+SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
+
+SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0"
+SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}