aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoann Congal <yoann.congal@smile.fr>2024-05-21 10:08:05 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-21 14:15:10 -0700
commitd161de0b00b91cd0c286fbbc1190f87cf20fe088 (patch)
tree0644fb237920f2f554ad7a25a85002c61022a0b7
parent3584b79a4cdc410ee4aaf12b57bccd0ce035537c (diff)
downloadmeta-openembedded-contrib-d161de0b00b91cd0c286fbbc1190f87cf20fe088.tar.gz
mdio-tools: fix mdio-netlink kernel module reproducibility
mdio-netlink source make reference to ${S}/.. which breaks -fdebug-prefix-map and results in the full TMPDIR path being present in the -dbg package and, also, change a related CRC in the main package. This changes ${S} to enclose the whole SRC_URI repo and adapt relative paths to build (MODULES_MODULE_SYMVERS_LOCATION) This make mdio-netlink reproducible and fixes this warning: WARNING: mdio-netlink-1.3.1-r0 do_package_qa: QA Issue: File /lib/modules/6.6.29-yocto-standard/updates/.debug/mdio-netlink.ko in package mdio-netlink-dbg contains reference to TMPDIR [buildpaths] Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Reviewed-by: Alexandre Truong <alexandre.truong@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rwxr-xr-xmeta-networking/conf/include/non-repro-meta-networking.inc2
-rw-r--r--meta-networking/recipes-support/mdio-tools/mdio-netlink_1.3.1.bb5
2 files changed, 3 insertions, 4 deletions
diff --git a/meta-networking/conf/include/non-repro-meta-networking.inc b/meta-networking/conf/include/non-repro-meta-networking.inc
index e0f448fe31..45eed5398e 100755
--- a/meta-networking/conf/include/non-repro-meta-networking.inc
+++ b/meta-networking/conf/include/non-repro-meta-networking.inc
@@ -15,7 +15,6 @@ KNOWN_NON_REPRO_META_NETWORKING = " \
htpdate-doc \
keepalived \
keepalived-dbg \
- kernel-module-mdio-netlink-6.6.17-yocto-standard \
libbearssl-staticdev \
libfko3 \
libfko-client \
@@ -25,7 +24,6 @@ KNOWN_NON_REPRO_META_NETWORKING = " \
libowfat-staticdev \
libruli-staticdev \
libsamba-util0 \
- mdio-netlink-dbg \
mosquitto \
mosquitto-dbg \
ncftp \
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-netlink_1.3.1.bb b/meta-networking/recipes-support/mdio-tools/mdio-netlink_1.3.1.bb
index b50d33f908..3867b89052 100644
--- a/meta-networking/recipes-support/mdio-tools/mdio-netlink_1.3.1.bb
+++ b/meta-networking/recipes-support/mdio-tools/mdio-netlink_1.3.1.bb
@@ -3,11 +3,12 @@ require mdio-tools.inc
DEPENDS += "virtual/kernel libmnl"
# This module requires Linux 5.6 higher
-S = "${WORKDIR}/git/kernel"
+S = "${WORKDIR}/git"
inherit module
-EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
+EXTRA_OEMAKE = "-C kernel/ KDIR=${STAGING_KERNEL_DIR}"
+MODULES_MODULE_SYMVERS_LOCATION="kernel"
MODULES_INSTALL_TARGET = "install"
RPROVIDES:${PN} += "kernel-module-mdio-netlink"