aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-04 10:28:55 -0800
committerKhem Raj <raj.khem@gmail.com>2024-01-04 22:47:08 -0800
commitb1a7262087a88e2d6987363e499b6ed97667baa7 (patch)
treee9cc71b4d1c0370424426a519c6a01c038568d01
parenta7bbf879b5a085199132d0b385161b8c5a29660e (diff)
downloadmeta-openembedded-contrib-b1a7262087a88e2d6987363e499b6ed97667baa7.tar.gz
libcppkafka: Update to tip of trunk
Fix the PV to point to last release + git as 0.4.0 is unreleased yet Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libcppkafka/libcppkafka/0001-cmake-Use-CMAKE_INSTALL_LIBDIR.patch30
-rw-r--r--meta-oe/recipes-support/libcppkafka/libcppkafka_git.bb12
2 files changed, 8 insertions, 34 deletions
diff --git a/meta-oe/recipes-support/libcppkafka/libcppkafka/0001-cmake-Use-CMAKE_INSTALL_LIBDIR.patch b/meta-oe/recipes-support/libcppkafka/libcppkafka/0001-cmake-Use-CMAKE_INSTALL_LIBDIR.patch
deleted file mode 100644
index d78ee7a8df..0000000000
--- a/meta-oe/recipes-support/libcppkafka/libcppkafka/0001-cmake-Use-CMAKE_INSTALL_LIBDIR.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 51ec4c1f533dee9a499490c1c5bbd23d2191a4a7 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 20 Mar 2022 11:14:25 -0700
-Subject: [PATCH] cmake: Use CMAKE_INSTALL_LIBDIR
-
-Do not hardcode library path, this helps it install in right location
-independent of platforms, e.g. ppc64 uses lib64 and not lib
-
-Upstream-Status: Submitted [https://github.com/mfontanini/cppkafka/pull/291]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c4e44e6..25ec1ce 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -51,7 +51,7 @@ option(CPPKAFKA_EXPORT_CMAKE_CONFIG "Generate CMake config, target and version f
- set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake/")
-
- if (NOT CPPKAFKA_CONFIG_DIR)
-- set(CPPKAFKA_CONFIG_DIR lib/cmake/${PROJECT_NAME})
-+ set(CPPKAFKA_CONFIG_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME})
- endif()
-
- # Maintain previous compatibility
---
-2.35.1
-
diff --git a/meta-oe/recipes-support/libcppkafka/libcppkafka_git.bb b/meta-oe/recipes-support/libcppkafka/libcppkafka_git.bb
index fd57e4e283..cf2d933169 100644
--- a/meta-oe/recipes-support/libcppkafka/libcppkafka_git.bb
+++ b/meta-oe/recipes-support/libcppkafka/libcppkafka_git.bb
@@ -9,17 +9,21 @@ file://LICENSE;md5=d8b4ca15d239dc1485ef495c8f1bcc72 \
"
SRC_URI = "git://github.com/mfontanini/cppkafka;protocol=https;branch=master \
- file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR.patch \
"
-SRCREV = "5e4b350806d561473138ce7a982e8f6cf2e77733"
+SRCREV = "91ac543cbd2228588dcf24a6ca357f8be0f4e5ab"
-DEPENDS = "librdkafka boost chrpath-replacement-native"
+BASEPV = "0.4.0"
+PV = "${BASEPV}+git"
+
+DEPENDS = "librdkafka curl boost chrpath-replacement-native"
inherit cmake
+EXTRA_OECMAKE = "-DCPPKAFKA_BUILD_SHARED=ON"
+
S = "${WORKDIR}/git"
do_install:append(){
- chrpath -d ${D}${libdir}/libcppkafka.so.0.3.1
+ chrpath -d ${D}${libdir}/libcppkafka.so.${BASEPV}
sed -i -e 's|${STAGING_INCDIR}|\$\{includedir\}|g' ${D}${datadir}/pkgconfig/cppkafka.pc
}