aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-03 18:50:50 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-03 16:43:10 -0700
commitaa644a8bc575080ee0cb922166249d1205f3c4ad (patch)
treeb0471cd8ae4a3a330a0024a61ddd41b136ff5fa9
parent490858976f7e5f7d659d0a803d7da28487387d53 (diff)
downloadmeta-openembedded-contrib-aa644a8bc575080ee0cb922166249d1205f3c4ad.tar.gz
python-wrapt: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-wrapt.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-wrapt_1.12.1.bb17
2 files changed, 15 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-wrapt.inc b/meta-python/recipes-devtools/python/python-wrapt.inc
deleted file mode 100644
index f4a8f19513..0000000000
--- a/meta-python/recipes-devtools/python/python-wrapt.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "A Python module for decorators, wrappers and monkey patching."
-HOMEPAGE = "http://wrapt.readthedocs.org/"
-LICENSE = "BSD-2-Clause"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=fdfc019b57affbe1d7a32e3d34e83db4"
-
-SRC_URI[md5sum] = "6d56ed0de4336462a73350341462f45e"
-SRC_URI[sha256sum] = "b62ffa81fb85f4332a4f609cab4ac40709470da05643a082ec1eb88e6d9b97d7"
-
-inherit pypi
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-stringold \
- ${PYTHON_PN}-threading \
-"
diff --git a/meta-python/recipes-devtools/python/python3-wrapt_1.12.1.bb b/meta-python/recipes-devtools/python/python3-wrapt_1.12.1.bb
index 85f446ef98..49fde1003d 100644
--- a/meta-python/recipes-devtools/python/python3-wrapt_1.12.1.bb
+++ b/meta-python/recipes-devtools/python/python3-wrapt_1.12.1.bb
@@ -1,2 +1,15 @@
-inherit setuptools3
-require python-wrapt.inc
+SUMMARY = "A Python module for decorators, wrappers and monkey patching."
+HOMEPAGE = "http://wrapt.readthedocs.org/"
+LICENSE = "BSD-2-Clause"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fdfc019b57affbe1d7a32e3d34e83db4"
+
+SRC_URI[md5sum] = "6d56ed0de4336462a73350341462f45e"
+SRC_URI[sha256sum] = "b62ffa81fb85f4332a4f609cab4ac40709470da05643a082ec1eb88e6d9b97d7"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"