aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:13 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:34 -0800
commita55a9b65f4c553a27533ab3a671149c44ff28566 (patch)
treee11ed99d5d0ac301c3fe654d209f9cb433786c36
parent0ba05a291773487b5178caedfd9f010d680a5295 (diff)
downloadmeta-openembedded-contrib-a55a9b65f4c553a27533ab3a671149c44ff28566.tar.gz
python3-xlrd: switch to pytest --automake
Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd/run-ptest b/meta-python/recipes-devtools/python/python3-xlrd/run-ptest
index 3385d68939..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-xlrd/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
index 5e63d3c307..8a9af14d3e 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
@@ -30,6 +30,7 @@ RDEPENDS:${PN} += " \
RDEPENDS:${PN}-ptest += " \
python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {