aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordl9pf@gmx.de <dl9pf@gmx.de>2020-02-19 12:56:54 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-19 09:36:13 -0800
commit876f4ce7639def476664834acafbf87cc227fb05 (patch)
treee5573a1e57d4ddadf3065736f9e703bb0e8985cf
parent696408ce3661b663a7895f75a01613e6cfeb8186 (diff)
downloadmeta-openembedded-contrib-876f4ce7639def476664834acafbf87cc227fb05.tar.gz
meta-oe: master: remmina - use PACKAGECONFIG for spice
remmina depends on spice and spice-protocol but they are in meta-networking. Use the PACKAGECONFIG flag to avoid hardcoding the dependency. Signed-off-by: Jan-Simon Moeller <dl9pf@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/remmina/remmina_1.3.6.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
index f9963ff65e..f9860a11fb 100644
--- a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
+++ b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
@@ -5,8 +5,6 @@ LICENSE = "GPLv2 & openssl"
LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769"
DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi-ui libsodium libssh vte json-glib libsoup-2.4 libvncserver libsecret"
-DEPENDS_append_x86 = " spice spice-protocol"
-DEPENDS_append_x86-64 = " spice spice-protocol"
DEPENDS_append_libc-musl = " libexecinfo"
LDFLAGS_append_libc-musl = " -lexecinfo"
@@ -23,11 +21,7 @@ inherit cmake features_check mime-xdg
# depends on avahi-ui with this restriction
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
-EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF -DWITH_SPICE=OFF"
-
-EXTRA_OECMAKE_append_x86 = " -DWITH_SPICE=ON"
-EXTRA_OECMAKE_append_x86-64 = " -DWITH_SPICE=ON"
-
+EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF"
do_install_append(){
# We dont need the extra stuff form other desktop environments
@@ -36,6 +30,8 @@ do_install_append(){
rm -rf ${D}/${datadir}/gnome-session
}
+PACKAGECONFIG[spice] = "-DWITH_SPICE=ON, -DWITH_SPICE=OFF, spice spice-protocol"
+
RDEPENDS_${PN} = "bash"
FILES_${PN}_append = " ${datadir}/icons/hicolor/*"