aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya A. Kriveshko <iillyyaa@gmail.com>2024-01-02 17:24:59 -0500
committerKhem Raj <raj.khem@gmail.com>2024-01-03 09:14:13 -0800
commit7b66ea10817f90fe4b869de7b3b04d3aa4b2714f (patch)
tree135933ae2d2f3ea1c0fb611627822844af6580bb
parent13a1b1b1a56b41d23933ee5113a338ad5e5156fc (diff)
downloadmeta-openembedded-contrib-7b66ea10817f90fe4b869de7b3b04d3aa4b2714f.tar.gz
srecord: fix install prefix
srecord's CMakeLists.txt was unconditionally setting CMAKE_INSTALL_PREFIX for non-WIN32 builds, which caused it to ignore OE-supplied prefix that contained the sysroot portion of the path. Fixed by setting the prefix only if it wasn't explicitly provided. Signed-off-by: Ilya A. Kriveshko <iillyyaa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/srecord/files/0001-cmake-respect-explicit-install-prefix.patch31
-rw-r--r--meta-oe/recipes-support/srecord/srecord_1.65.0.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/srecord/files/0001-cmake-respect-explicit-install-prefix.patch b/meta-oe/recipes-support/srecord/files/0001-cmake-respect-explicit-install-prefix.patch
new file mode 100644
index 0000000000..5a74323bca
--- /dev/null
+++ b/meta-oe/recipes-support/srecord/files/0001-cmake-respect-explicit-install-prefix.patch
@@ -0,0 +1,31 @@
+From 4aa8cf8c93e1fa6ffeb40fc3473f32b1b83af141 Mon Sep 17 00:00:00 2001
+From: "Ilya A. Kriveshko" <iillyyaa@gmail.com>
+Date: Tue, 2 Jan 2024 15:37:10 -0500
+Subject: [PATCH] cmake: respect explicit install prefix
+
+If CMAKE_INSTALL_PREFIX was supplied externally, use it. This follows
+the pattern suggested by cmake documentation in:
+https://cmake.org/cmake/help/latest/variable/CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT.html
+
+Upstream-status: Submitted [https://github.com/sierrafoxtrot/srecord/pull/68]
+---
+ CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 74b8108c..ac9f464e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -30,9 +30,9 @@ include(InstallRequiredSystemLibraries)
+ include(GNUInstallDirs)
+
+ # FHS compliant paths for Linux installation
+-if(NOT WIN32 AND CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
+-# set(CMAKE_INSTALL_PREFIX "/opt/${PROJECT_NAME}")
+- set(CMAKE_INSTALL_PREFIX "/usr")
++if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT
++ AND NOT WIN32 AND CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
++ set(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "Install prefix" FORCE)
+ endif()
+
+ # Pull in the rest of the pieces
diff --git a/meta-oe/recipes-support/srecord/srecord_1.65.0.bb b/meta-oe/recipes-support/srecord/srecord_1.65.0.bb
index 06ce48e65c..3e8a87d07f 100644
--- a/meta-oe/recipes-support/srecord/srecord_1.65.0.bb
+++ b/meta-oe/recipes-support/srecord/srecord_1.65.0.bb
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
SRC_URI = " \
https://sourceforge.net/projects/${BPN}/files/srecord/${@oe.utils.trim_version('${PV}', 2)}/${BP}-Source.tar.gz \
file://0001-Disable-doxygen.patch \
- file://0001-cmake-Do-not-try-to-compute-library-dependencies-dur.patch"
+ file://0001-cmake-Do-not-try-to-compute-library-dependencies-dur.patch \
+ file://0001-cmake-respect-explicit-install-prefix.patch"
SRC_URI[sha256sum] = "81c3d07cf15ce50441f43a82cefd0ac32767c535b5291bcc41bd2311d1337644"
S = "${WORKDIR}/${BP}-Source"