aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamantha Jalabert <samantha.jalabert@syslinbit.com>2023-09-25 11:41:40 +0000
committerKhem Raj <raj.khem@gmail.com>2023-09-26 21:16:03 -0700
commit6f1261a66d49a8f2130ad438579582eb8761da0e (patch)
tree5c57a6ef8d0c1baa92142cee5a1be40b991864da
parent1beedf1eb71d80f66ff33addee918e79b275c907 (diff)
downloadmeta-openembedded-contrib-6f1261a66d49a8f2130ad438579582eb8761da0e.tar.gz
Remove python3-click
python3-click recipe is moved to openembedded-core. Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com> Signed-off-by: Samantha Jalabert <samantha.jalabert@syslinbit.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-click/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-click_8.1.7.bb39
2 files changed, 0 insertions, 42 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click/run-ptest b/meta-python/recipes-devtools/python/python3-click/run-ptest
deleted file mode 100644
index b63c4de0d9..0000000000
--- a/meta-python/recipes-devtools/python/python3-click/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-click_8.1.7.bb b/meta-python/recipes-devtools/python/python3-click_8.1.7.bb
deleted file mode 100644
index a4ec6cd1ef..0000000000
--- a/meta-python/recipes-devtools/python/python3-click_8.1.7.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
-DESCRIPTION = "\
-Click is a Python package for creating beautiful command line interfaces \
-in a composable way with as little code as necessary. It's the "Command \
-Line Interface Creation Kit". It's highly configurable but comes with \
-sensible defaults out of the box."
-HOMEPAGE = "http://click.pocoo.org/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
-
-SRC_URI[sha256sum] = "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de"
-
-inherit pypi setuptools3 ptest
-
-SRC_URI += "file://run-ptest"
-
-RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-terminal \
- ${PYTHON_PN}-unixadmin \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
- cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
- cp -rf ${S}/docs ${D}${PTEST_PATH}/
-}
-
-UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
-
-CLEANBROKEN = "1"
-
-RDEPENDS:${PN} += "\
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-threading \
- "
-
-BBCLASSEXTEND = "native nativesdk"