aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHao Jiang <jianghao@google.com>2022-05-19 14:21:30 -0700
committerKhem Raj <raj.khem@gmail.com>2022-10-12 19:19:27 -0700
commit6e2cfa4113766f703e55d711bf59ed3c8f17d5a2 (patch)
tree78c40706e7f22defb0a733e5c13b6b3f7a47d48c
parent2467e6c82d146d0f257f7f0f92a5a958ff1b3cb7 (diff)
downloadmeta-openembedded-contrib-6e2cfa4113766f703e55d711bf59ed3c8f17d5a2.tar.gz
mctp: install the .target files
Need the targets file to enable the mctpd.service on systemd. Signed-off-by: Hao Jiang <jianghao@google.com> Change-Id: I8d48d3767760dc1f34ae7e1266600d350ac93281
-rw-r--r--meta-networking/recipes-support/mctp/mctp_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/mctp/mctp_git.bb b/meta-networking/recipes-support/mctp/mctp_git.bb
index 516f3e2d9e..9e97a6a60a 100644
--- a/meta-networking/recipes-support/mctp/mctp_git.bb
+++ b/meta-networking/recipes-support/mctp/mctp_git.bb
@@ -22,13 +22,16 @@ PACKAGECONFIG ??= " \
# mctpd will only be built if pkg-config detects libsystemd; in which case
# we'll want to declare the dep and install the service.
PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
-SYSTEMD_SERVICE:${PN} = "mctpd.service"
+SYSTEMD_SERVICE:${PN} = "mctpd.service mctp.target mctp-local.target"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"
do_install:append () {
if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${S}/conf/mctpd.service \
${D}${systemd_system_unitdir}/mctpd.service
+ install -m 0644 ${S}/conf/*.target \
+ ${D}${systemd_system_unitdir}/
install -d ${D}${datadir}/dbus-1/system.d
install -m 0644 ${S}/conf/mctpd-dbus.conf \
${D}${datadir}/dbus-1/system.d/mctpd.conf