aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-11-29 13:34:45 +0800
committerKhem Raj <raj.khem@gmail.com>2019-11-30 00:13:53 -0800
commit6bc470c15e493765a917908abeae56a12182131a (patch)
tree4350c9b60b5381d225db0f8ccd08a3528920affc
parente875bc8ef59f1257a712174ea11548be1fb74fd9 (diff)
downloadmeta-openembedded-contrib-6bc470c15e493765a917908abeae56a12182131a.tar.gz
python3-django: upgrade 1.11.14 -> 2.2.7
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-django.inc3
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.11.14.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-django_1.11.14.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-django_2.2.7.bb9
4 files changed, 12 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc
index ee3aee638f..63d025d54a 100644
--- a/meta-python/recipes-devtools/python/python-django.inc
+++ b/meta-python/recipes-devtools/python/python-django.inc
@@ -3,9 +3,6 @@ HOMEPAGE = "http://www.djangoproject.com/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
-SRC_URI[md5sum] = "38e82b59a1c27bbf98ccf0564ead7426"
-SRC_URI[sha256sum] = "eb9271f0874f53106a2719c0c35ce67631f6cc27cf81a60c6f8c9817b35a3f6e"
-
PYPI_PACKAGE = "Django"
inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-django_1.11.14.bb b/meta-python/recipes-devtools/python/python-django_1.11.14.bb
index d2347cc963..efe23dcb72 100644
--- a/meta-python/recipes-devtools/python/python-django_1.11.14.bb
+++ b/meta-python/recipes-devtools/python/python-django_1.11.14.bb
@@ -1,6 +1,9 @@
require python-django.inc
inherit setuptools
+SRC_URI[md5sum] = "38e82b59a1c27bbf98ccf0564ead7426"
+SRC_URI[sha256sum] = "eb9271f0874f53106a2719c0c35ce67631f6cc27cf81a60c6f8c9817b35a3f6e"
+
RDEPENDS_${PN} += " \
${PYTHON_PN}-argparse \
${PYTHON_PN}-subprocess \
diff --git a/meta-python/recipes-devtools/python/python3-django_1.11.14.bb b/meta-python/recipes-devtools/python/python3-django_1.11.14.bb
deleted file mode 100644
index e1e38c3225..0000000000
--- a/meta-python/recipes-devtools/python/python3-django_1.11.14.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-django.inc
-inherit setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-django_2.2.7.bb b/meta-python/recipes-devtools/python/python3-django_2.2.7.bb
new file mode 100644
index 0000000000..e56453abc1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-django_2.2.7.bb
@@ -0,0 +1,9 @@
+require python-django.inc
+inherit setuptools3
+
+SRC_URI[md5sum] = "b0833024aac4c8240467e4dc91a12e9b"
+SRC_URI[sha256sum] = "16040e1288c6c9f68c6da2fe75ebde83c0a158f6f5d54f4c5177b0c1478c5b86"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-sqlparse \
+"