aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-01-14 09:39:08 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commit5dd27b4a9f42c57bbba8b69ac179924dfaab0b76 (patch)
treefe89eb16730190af06419b87e9ea0afe15188f47
parent57d127e81e5778ee8ab418a03f73ff277f3d1b9f (diff)
downloadmeta-openembedded-contrib-5dd27b4a9f42c57bbba8b69ac179924dfaab0b76.tar.gz
openldap: ignore the mkdir errors in Makefile
Ignore the mkdir errors to fix the parallel build failure: ../../build/shtool mkdir -p TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib mkdir: cannot create directory 'TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib': File exists make[1]: *** [Makefile:288: install-local] Error 1 Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch33
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.5.9.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch b/meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch
new file mode 100644
index 0000000000..552726bb0a
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch
@@ -0,0 +1,33 @@
+From 690f69791eb6cd0d7e94b4d73219ee864de27f62 Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Mon, 10 Jan 2022 10:13:51 +0800
+Subject: [PATCH] libraries/Makefile.in: ignore the mkdir errors
+
+Ignore the mkdir errors to fix the parallel build failure:
+
+../../build/shtool mkdir -p TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib
+mkdir: cannot create directory 'TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib': File exists
+
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ libraries/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libraries/Makefile.in b/libraries/Makefile.in
+index d9cb2ff..c6b251f 100644
+--- a/libraries/Makefile.in
++++ b/libraries/Makefile.in
+@@ -24,7 +24,7 @@ PKGCONFIG_DIR=$(DESTDIR)$(libdir)/pkgconfig
+ PKGCONFIG_SRCDIRS=liblber libldap
+
+ install-local:
+- @$(MKDIR) $(PKGCONFIG_DIR)
++ @-$(MKDIR) $(PKGCONFIG_DIR)
+ @for i in $(PKGCONFIG_SRCDIRS); do \
+ $(INSTALL_DATA) $$i/*.pc $(PKGCONFIG_DIR); \
+ done
+--
+2.17.1
+
diff --git a/meta-oe/recipes-support/openldap/openldap_2.5.9.bb b/meta-oe/recipes-support/openldap/openldap_2.5.9.bb
index c008c7b4bc..f3b8c6c987 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.5.9.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.5.9.bb
@@ -22,6 +22,7 @@ SRC_URI = "http://www.openldap.org/software/download/OpenLDAP/openldap-release/$
file://remove-user-host-pwd-from-version.patch \
file://0001-ldif-filter-fix-parallel-build-failure.patch \
file://0001-build-top.mk-unset-STRIP_OPTS.patch \
+ file://0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch \
"
SRC_URI[md5sum] = "237fc2d881c27f8dd5d9f396e2865c11"