aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-10 18:53:13 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-10 22:26:43 +0200
commit5d10b56c9cbd4fe108e8fa575c934abf53979e16 (patch)
tree03accc9dd919432d5616a2ede1958b2412150c98
parent261c710e5262c4ff5de03b536ae520b2c85daa96 (diff)
downloadmeta-openembedded-contrib-5d10b56c9cbd4fe108e8fa575c934abf53979e16.tar.gz
system-tools-backends: add 2.10.2
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/add-angstrom-distro.patch41
-rw-r--r--meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/system-tools-backends74
-rw-r--r--meta-gnome/recipes-gnome/system-tools/system-tools-backends_2.10.2.bb52
3 files changed, 167 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/add-angstrom-distro.patch b/meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/add-angstrom-distro.patch
new file mode 100644
index 0000000000..cb03fd86e5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/add-angstrom-distro.patch
@@ -0,0 +1,41 @@
+From b5084616a3bc2a0d485f43aeae69c6025f3f857e Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 10 Jun 2011 18:44:21 +0200
+Subject: [PATCH] add support for the angstrom distribtion
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ Utils/Platform.pm | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/Utils/Platform.pm b/Utils/Platform.pm
+index fc76360..8b8c770 100644
+--- a/Utils/Platform.pm
++++ b/Utils/Platform.pm
+@@ -92,6 +92,7 @@ my $PLATFORM_INFO = {
+ "nexenta-1.0" => [ "Nexenta GNU/Solaris", "1.0", "Ellate" ],
+ "yellowdog-4.1" => [ "Yellow Dog Linux", "4.1", "Sagitta" ],
+ "guadalinex-v4" => [ "Guadalinex", "v4", "Toro" ],
++ "angstrom" => [ "Angstrom", "", "" ],
+ };
+
+ sub get_platform_info
+@@ -143,6 +144,7 @@ sub ensure_distro_map
+ "vine-3.1" => "vine-3.0",
+ "vlos-1.2" => "gentoo",
+ "nexenta-1.0" => "solaris-2.11",
++ "angstrom" => "debian",
+ );
+
+ return $metamap{$distro} if ($metamap{$distro});
+@@ -375,6 +377,7 @@ sub guess
+ [ \&check_ark ],
+ [ \&check_yoper ],
+ [ \&check_distro_file, "/etc/yellowdog-release", "yellowdog", "^Yellow Dog Linux release (\\S+)" ],
++ [ \&check_file_exists, "/etc/angstrom-version", "angstrom" ],
+ ],
+ "FreeBSD" => [[ \&check_freebsd ]],
+ "SunOS" => [[ \&check_solaris ]]
+--
+1.6.6.1
+
diff --git a/meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/system-tools-backends b/meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/system-tools-backends
new file mode 100644
index 0000000000..704c36dbf4
--- /dev/null
+++ b/meta-gnome/recipes-gnome/system-tools/system-tools-backends-2.10.2/system-tools-backends
@@ -0,0 +1,74 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides: system-tools-backends
+# Required-Start: $local_fs dbus
+# Required-Stop: $local_fs dbus
+# Should-Start: $syslog
+# Should-Stop: $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 1
+# Short-Description: Gnome System Tools Backends
+# Description: The Gnome System Tools Backends daemon handles root-needed
+# operations to configure your machine with the Gnome System
+# Tools.
+### END INIT INFO
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/bin/system-tools-backends
+PIDDIR=/var/run
+PIDFILE=$PIDDIR/system-tools-backends.pid
+NAME=system-tools-backends
+DESC="System Tools Backends"
+
+test -x $DAEMON || exit 0
+
+set -e
+
+do_start() {
+ echo "Starting $DESC"
+ start-stop-daemon --start --startas $DAEMON --quiet --pidfile $PIDFILE
+}
+
+do_stop() {
+ echo "Stopping $DESC"
+ start-stop-daemon --stop --oknodo --quiet --pidfile $PIDFILE --startas $DAEMON
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ stop)
+ do_stop
+ ;;
+ #reload)
+ #
+ # If the daemon can reload its config files on the fly
+ # for example by sending it SIGHUP, do it here.
+ #
+ # If the daemon responds to changes in its config file
+ # directly anyway, make this a do-nothing entry.
+ #
+ # echo "Reloading $DESC configuration files."
+ # start-stop-daemon --stop --signal 1 --quiet --pidfile \
+ # /var/run/$NAME.pid --exec $DAEMON
+ #;;
+ restart|force-reload)
+ #
+ # If the "reload" option is implemented, move the "force-reload"
+ # option to the "reload" entry above. If not, "force-reload" is
+ # just the same as "restart".
+ #
+ do_stop
+ sleep 5
+ do_start
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|reload|force-reload|status}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
+
diff --git a/meta-gnome/recipes-gnome/system-tools/system-tools-backends_2.10.2.bb b/meta-gnome/recipes-gnome/system-tools/system-tools-backends_2.10.2.bb
new file mode 100644
index 0000000000..ef696f8fe7
--- /dev/null
+++ b/meta-gnome/recipes-gnome/system-tools/system-tools-backends_2.10.2.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "gnome system tools backends"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "dbus dbus-glib glib-2.0 polkit"
+
+inherit gnome pkgconfig update-rc.d gettext
+
+SRC_URI[archive.md5sum] = "edae148b31342aecae035051adc70c74"
+SRC_URI[archive.sha256sum] = "1dbe5177df46a9c7250735e05e77129fe7ec04840771accfa87690111ca2c670"
+
+SRC_URI += " \
+ file://system-tools-backends \
+ "
+
+# This needs to move to meta-angstrom
+SRC_URI_append_angstrom = " \
+ file://add-angstrom-distro.patch \
+ "
+
+EXTRA_OECONF = " --with-net-dbus=${libdir}/perl5 "
+
+do_configure() {
+ rm missing || true
+ automake --add-missing
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.am
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.in
+ libtoolize --force --install
+ aclocal
+ gnu-configize
+ oe_runconf
+ cp ${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool ${S}
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/system-tools-backends ${D}/${sysconfdir}/init.d/
+}
+
+INITSCRIPT_NAME = "system-tools-backends"
+INITSCRIPT_PARAMS = "start 50 2 3 4 5 . stop 70 1 ."
+
+# Shadow added so there is a full adduser/deluser
+# (Gnome images tend to pull in shadow anyway)
+RDEPENDS_${PN} = "shadow"
+
+FILES_${PN} += " ${sysconfdir}/dbus-1/system.d"
+FILES_${PN} += " ${libdir}/pkgconfig"
+FILES_${PN} += " ${datadir}/dbus-1/system-services"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/files"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/scripts"
+FILES_${PN} += " ${datadir}/polkit*"