aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:29 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:36 -0800
commit441da99311afee0963fb4a8cbd45ec8350ce4cf2 (patch)
tree8f92786f3e29cbb5a0ab06d86134f3f9f27d6263
parent2192056f6729e7de540784337e37860c51d61e04 (diff)
downloadmeta-openembedded-contrib-441da99311afee0963fb4a8cbd45ec8350ce4cf2.tar.gz
python3-ansicolors: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Be careful to point pytest at the test.py file Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-ansicolors/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb3
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ansicolors/run-ptest b/meta-python/recipes-devtools/python/python3-ansicolors/run-ptest
index 7dc3ef32be..922353a1f3 100644
--- a/meta-python/recipes-devtools/python/python3-ansicolors/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-ansicolors/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO test.py| sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake test.py
diff --git a/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb b/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
index 0e32443992..b63cc32a23 100644
--- a/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
+++ b/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
@@ -14,7 +14,8 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {