aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Gotthard <petr.gotthard@advantech.cz>2023-02-24 17:20:16 +0000
committerKhem Raj <raj.khem@gmail.com>2023-02-24 09:49:07 -0800
commit4370e3d3fb81c6557295face5e66d3261ed5b51b (patch)
tree09e47d0ef702e00bd4f40cc0a7fa1993eda2b000
parent0a6087c60302e94ae95cbe64d99fe2246c97cdb8 (diff)
downloadmeta-openembedded-contrib-4370e3d3fb81c6557295face5e66d3261ed5b51b.tar.gz
python3-scapy: upgrade 2.4.5 -> 2.5.0
Changelog: https://github.com/secdev/scapy/releases/tag/v2.5.0 Also, in this version the UTscapy wrapper gets no longer installed into /usr/bin, so for ptest we need to install it. Signed-off-by: Petr Gotthard <petr.gotthard@advantech.cz> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy/run-ptest2
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb (renamed from meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb)6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-scapy/run-ptest b/meta-networking/recipes-devtools/python/python3-scapy/run-ptest
index 797d8ecf78..417e21053c 100644
--- a/meta-networking/recipes-devtools/python/python3-scapy/run-ptest
+++ b/meta-networking/recipes-devtools/python/python3-scapy/run-ptest
@@ -1,4 +1,4 @@
#!/bin/sh
-UTscapy3 -t regression.uts -f text -l -C \
+python3 UTscapy.py -t regression.uts -f text -l -C \
-o @PTEST_PATH@/scapy_ptest_$(date +%Y%m%d-%H%M%S).log \
2>&1 | sed -e 's/^passed None/PASS:/' -e 's/^failed None/FAIL:/'
diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
index 0f66dfd784..cc3f2ee1dd 100644
--- a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
+++ b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
# If you want ptest support, use the git repo
# UTscapy does not exist in the pypi pkg
#
-SRCREV = "32cd7eb0f620d9adf171c48d55514e8326a538d7"
+SRCREV = "9473f77d8b548c8e478e52838bdd4c12f5d4f4ff"
SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \
file://run-ptest"
@@ -28,14 +28,14 @@ inherit setuptools3 ptest
do_install:append() {
mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
- mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3
}
do_install_ptest() {
+ install -m 0644 ${S}/scapy/tools/UTscapy.py ${D}${PTEST_PATH}
install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
}
RDEPENDS:${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
- ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
+ ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-fcntl"